Skip to end of metadata
Go to start of metadata

Overview

The Character Tool is used for setting up character definitions by importing assets authored in third party tools and making them available to be used within CRYENGINE. A fully authored character usually consists of models, skeleton, physical properties and an associated animation set. The tool also enables interactive control and adjustment of animations as well as the collider proxy setup. The latter is used for interaction with the physical world in the game.

Icon
The concept of the character tool is not only associated with Characters (Humans, animals etc.) Think of the tool in a way that handles all objects with animations associated with them. i.e. Characters (cdf), weapons (cdf) vehicles (cga) etc.

Importing

Importing a file into the Character Tool can be done by dragging&dropping; simply drag the file from the folder in your Windows Explorer into the viewport of the Character Tool.

Icon

Keep in mind that when an *.fbx file contains several skins, only one skin can be imported.

Character Tool View Pane

To open the Character Tool, go to Tools -> Animation -> Character Tool.

Here are five core UI components of Character Tool:

  1. Viewport – here the loaded character will be shown.
  2. Assets - here you can locate character related assets: characters, skeletons, animations and compression settings.
  3. Scene Parameters – here the scene is defined. This component shows the selected character, animation layers and animation parameters that are used to preview assets.
  4. Properties – here you will see properties of assets, like Character Definition, Skeleton Parameters or Animation Settings.
  5. Playback – here you can see the playback options and timeline. It is used for animation playback and animation events editing.

Note that all of the panels are dockable and can be moved out. 

Viewport

The Viewport uses Sandbox standard navigation: WASD for movement, RMB for camera rotation and Middle mouse to pan the camera.

You can change various Viewport settings on the Display Options panel, which is located on the top-right of the Viewport:

Assets

The Assets panel is the core of the Character Tool UI. It is placed on the left side of the window by default:

It gives an overview of all character-related assets.

As soon as you select an entry of your interest, its properties will appear in the Properties panel on the right side.

Context Menu (right-click)

Each item within the tree has a context menu with available actions, for example for animations you will see:

There are multiple ways to filter the tree in the Assets panel:

  • By name – it is possible to specify multiple strings separated by space to look for sub-strings, i.e. "walk relaxed" will look for any name that contains both "walk" and "relaxed"
  • By type i.e: All, Animations, Characters, Compression and Skeletons

Multiple Assets Panes

You can have multiple instances of the Assets panel open. To create a new one use the Split Pane button in the title of the Assets panel:

Columns

Note that right clicking on the tree header (where the Name string is shown) opens a context menu that allows you to show additional columns like Size, Pak and Audio events:

Scene Parameters

A scene is setup only for previewing purposes and consists of:

  • Character – you can use this entry to load a new character by clicking on the Folder button. (this is an alternative way to select a character as opposed to selecting from the Asset tree panel on the left side)
  • Animation Layers – here the played animations are set up. Whenever you select an animation in the Assets panel, one will be assigned to the active animation layer (highlighted with a bold text and pressed button)
    You can add new animation layers by using the little button located next to it
    You can remove animation layers through the context menu (RMB on the number left to the layer button)
    Blend spaces, aim- and look-poses expose additional settings
  • Blend Shape – show blend shape sliders, when the character contains blend shapes
  • Audio Setup – options here are used to preview sound foleys and footsteps
  • Run Feature Test – this option allows programmers to quickly add and run project-specific tests

Properties Panel

On the top of the panel you can find a toolbar with undo/redo buttons and actions available for the selected asset. These are the same actions available through the context menu in the Assets tree.

The rest of the panel shows properties of the selected asset. For characters it is CDF (Character Definition File) content with character attachments and for animations you will see compression settings and animation events.

Icon

Note that you can copy and paste each of the properties and also filter the property list by using the right click context menu!

Playback

The Playback panel at the bottom can be used to scrub the timeline and provides playback options like looping of animations and playback speed. You can also change the timeline to be represented in seconds, frames or normalize the timeline from 0 - 1. The options gear offers further control on organizing how the timeline is represented.

Layouts

The state of the Character Tool UI is preserved when you leave it, but nevertheless you can define and save your own UI layout for your specific need. You can use the layout menu to do so:

Importing/Exporting Animation Layer Stacks

It is possible to import and export stacks of Animation Layers that you have assigned to a character in order to simplify debugging of problems with animations.

Exporting

  1. Assign several animations to your charachter:
  2. Choose File -> Export Animation Layers
    The Animation Layer stack will be saved as an *.xml file.

Importing

To import these Animation Layers to another character, open that character and choose File -> Import Animation Layers