Skip to end of metadata
Go to start of metadata

Overview

The FBX  Importer loads animations, skeletons skins and static geometry meshes. The currently supported input formats are *.fbx, *.dxf, *dae, *.obj, and *.3ds (however, *.fbx is the preferred interchange format). In addition, the FBX Importer provides a graphical interface to change properties before they are imported to a CRYENGINE format.

Icon

The existing content pipeline, consisting of the 3ds Max and Maya exporters, still works. The FBX Importer, however, makes CRYENGINE more accessible to a greater variety of DCC tools, like Blender, so that artists can continue to use their favorite workflow.

The different importers can be found under Tools -> FBX Import.

Icon

Importing the animation, skeleton, skin or static geometry is very easy; you can just open the respective tool and drag&drop an *.fbx file from a folder in the Windows Explorer onto one of the tools.

Alternatively, you can also click File -> Import or use the Import button in the toolbar.


Basic Workflow of All Tools

The FBX Importer tools are typically used as follows:

  1. Open a source *.fbx (or other compatible) file. This can be done in one of three ways:
    - Going to File -> Import
    - Clicking the Import file button in the toolbar
    - Dragging & dropping a compatible file from the Windows Explorer onto the viewport of the tool you want to use
  2. Inspect the source scene and decide which meshes or nodes you want to export to the the output *.cgf file.
  3. When you're satisfied, click on File -> Save as (or click the Save as button in the toolbar) and save the file to the game folder.
  4. You will then be able to place it in your level by opening the Create Object tool and adding it in the way that you want, like for example a Brush or a Geom Entity, depending on what kind of asset you've made.
Icon

A *.cgf file must always be in the same folder as the *.fbx (or any compatible) file. The *.cgf references the *.fbx (or other compatible) file by name, not by path. The FBX Importer will automatically create a copy of the *.fbx file in the game folder, along with the output *.cgf file, when you click Save as...

The *.cgf file essentially stores all the settings you make in the MI and also a reference to the *.fbx file.

Icon

Load a level for proper lighting.

Icon
To import an entire asset including skin, animations and skeleton, you'll need to drag it onto the viewport of the Character Tool.

Animation

This will import the animations attached to the *.fbx file.

Pic1: Import Animation

1. Menu Bar

In the menu bar, there's one menu: the File menu.

File

OptionDescription
Open...Restores the FBX Importer dialog. This means the source *.fbx file is imported and the settings stored in the *.cgf file are applied. Works only with *.cgf files that have been written by the FBX Importer.
ImportImports a *.fbx, *.dxf, *.dae, *.obj or *.3ds file.
SaveOverwrites the current output file. (The current output file is the *.cgf file most recently written with Save as... or loaded with Open CGF). This option is disabled if no current output file exists.
Save As...Always shows a file dialog to specify the file path of the *.cgf file in the game folder. Also saves a copy of the source *.fbx (or other compatible) file to that same game folder, in which changes will be saved.

The FBX Importer will notify you if you attempt to overwrite a different *.fbx with the same filename this way.

2. Toolbar

The toolbar has the following buttons:

ButtonDescription
See above under File.
See above under File.

3. Clips/Root Motion Panel

Clips

Here you can decide which animations to import or even add animations. 

By clicking the button next to Animation clips, you can add new animations or remove all of the existing ones.

Removing a single animation clip is done by right-clicking on the number of the animation on the left and choosing Remove.

By clicking Preview this, you'll see the animation played out in the viewport.

Root Motion

By clicking Root motion, a node view appears. In this view you can optionally select a single node. if a node is selected, it acts as the ,"locomotion locator". see Setting up Locomotion Locator in 3ds Max.

4. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesShows all meshes.
Show selected nodeShows only the meshes belonging to the node selected in the node list.
Show selected subtreeShows only the meshes belonging to the subtree selected in the node list.

5. Display Options

In the top-right corner of the viewport is the Display Options button. Pressing this will open the Display Options menu.

This menu contains the following options:

View

OptionDescripiton
Joint namesShows/hides the names of the joints in the viewport.

Debug

OptionDescripiton
WireframeShows/hides the wireframe of the asset.
FramerateShows/hides the framerate in the viewports.

Camera

OptionDescription
Show Viewport OrientationShows an axis gizmo in the bottom-left corner of the viewports showing the orientation of the asset.
FOVChanges the Field of View. 
Near ClipA higher value means a larger distance of the near clipping plane to the camera. Increase this value if you experience depth buffer artifacts on objects further away from the camera. Decrease this value if objects appear to be cut off near the camera.
Move SpeedChanges the movement speed in left and right direction. Forward and back is always speed 0.7.
Rotation SpeedChanges the rotation speed of the camera.

Movement Smoothing

OptionDescription
Position

Basically "smears" translation of camera over time. Used to do smooth camera movements. A larger value means smoother transition over greater time span.

Rotation

Same as Position. Smoother camera rotations.

Grid

OptionDescription
Show GridShows/hides the grid.
Main ColorLets you change the color of the main grid lines.
Middle ColorLets you change the color of the middle grid lines.
SpacingChanges the distance between the grid lines.
Main LinesChanges the number of main grid lines.
Middle LinesChanges the number of middle grid lines.
OriginDraws a gizmo in the origin (position 0, 0, 0). Try it with an empty scene or wireframe mode to see the effect.

Lighting

OptionDescription
BrightnessChanges the brightness of the ambient light on the asset.
Ambient ColorChanges the color of the ambient light on the asset.
Rotate LightTurns continuous rotation of the directional light source on/off.
Light MultiplierUsed to dim or brighten the directional light.
Light Spec MultiplierChanges specular highlight on object from directional light.
Directional Light ColorSets the color of directional light.

Background

OptionDescription
Use GradientToggles between a gradient background and an evenly colored one.
Top ColorChanges the top color of the gradient background (if Use Gradient is unchecked, this will be the only color).
Bottom ColorChanges the bottom color of the gradient background.

Skeleton

This will import the skeleton attached to the *.fbx file.

Pic2: Import Skeleton

1. Menu Bar

In the menu bar, there's one menu: the File menu.

OptionDescription
Open...See here.
ImportSee here.
SaveSee here.
Save As...See here.

2. Toolbar

The toolbar has the following buttons:

3. Node List

In the Node List you can select which subtree or single node you want to import.

It also has a search bar at the top to quickly search for a specific node in case the asset has so many of them that it's hard to keep a good overview.

4. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesSee here.
Show selected nodeSee here.
Show selected subtreeSee here.

5. Display Options

See here.

Mesh

This part of the importer lets you import meshes and skins. The currently supported input formats are *.fbx, *.dxf, *.dae, *.obj, and *.3ds (however, *.fbx is the preferred format). In addition, the FBX Importer provides a graphical interface to change properties of the geometry that are specific to CRYENGINE, such as level of detail settings (LOD) and User-Defined Properties (UDP).

Pic4: Import Static Geometry

1. Menu Bar

The menu bar has the following options:

File

OptionDescription
Open...See here.
ImportSee here.
SaveSee here.
Save As...See here.

2. Toolbar

The toolbar has four buttons:

ButtonNameDescription
Import FileSee here.
Open CGFSee here.
SaveSee here.
Save asSee here.

3. Settings View

In the Settings view, you'll find general settings and settings related to the conversion of your scene.

General settings

 

Setting
Description
Input filename

Name of the file that was imported.

Output filename

This is the file that will be overwritten when you click Save.
It's either the last file you saved with Save as... or the file that you have opened with Open CGF.

 

Static Mesh Settings

 

SettingDescription
Merge all nodes

Combines all meshes on the same LOD to a single mesh.

NOTE: this is a rendering optimization and does not affect the pivots of the meshes.

Scene origin

By default, the RC ignores the local transformations of root nodes, which means that their pivots are placed at the world origin and meshes are translated accordingly. When Scene origin is enabled, the local transformation is applied and root nodes keep their world space position.

 

Conversion Settings

The conversion settings control the scale and orientation of the CGF mesh. Use these settings for example if the coordinate system of the DCC tool used to create the source file is different from CRYENGINE's coordinate system (in Maya, Y = up instead of Z).

Setting
Description
UnitChanges the unit of measurement in the mesh.
ScaleChanges the scale of the object. 
ForwardChanges which axis points forward. 
UpChanges which axis points upward.

Output Settings

 

SettingDescription
Use 32bit precisionIf enabled, vertex coordinates are stored with 32bit precision. If not enabled, they will be stored with 16bit precision.

4. Source/Target View

This panel can be changed between two different views, the Source view and the Target view, by clicking the buttons at the top.

Source View

Pic5: Source view

The Source view shows the node hierarchy, a list of materials in the source scene and a list of textures used. Essentially, it reflects the scene setup in the source file. Selecting any item displays its properties in the Properties panel (7).

Below the Search bar, this panel has two columns, Name and Type:

Column
Description
NameShows the name of the node.
TypeShows whether the node is an LOD, Physics Proxy or Skin and in the case of an LOD or Physics Proxy, lets you change which LOD it is or change it into a (invisible) physics proxy.

If possible, the LOD of a node can be changed by clicking in this column. Changing the LOD of a node is possible if it is a leaf node and the child of a mesh node.

If a node does not have a drop-down menu, it does not qualify as an LOD.

Right-Click Menus

When right-clicking on the column headers (Name, LOD), you can choose to show or hide either of these columns.

When right-clicking on a node, you get the following options: 

Option
Description
Include this nodeIncludes the node in the exported *.cgf file.
Exclude this nodeExcludes the node from the exported *.cgf file.
Select materials used by meshIn the material list on the right column, selects all the materials used by the currently selected mesh.
Auto Add ProxiesAutomatically adds proxies to your mesh. See here for more information about this feature.
Expand child nodesExpands all child nodes of the currently selected node.
Collapse child nodesCollapses all child nodes of the currently selected node.
Expand all nodesExpands the list of nodes.
Collapse all nodesCollapses the entire list of nodes.
Show only skinsShows only skin nodes.

NOTE: this simply does a search for "skin". To show other nodes again, delete the text from the Search bar.

Including and Excluding Nodes

By default, every node in the hierarchy is also included in the *.cgf file, indicated by the ticked box next to its name. You can exclude a node in the properties panel, or by right-clicking it in the node list. Conversely, if you untick a node, then its mesh will not appear in the *.cgf file.

Excluding a node excludes all of its children (so its entire subtree).

Example: consider a hierarchy A -> B -> C, where A is the root and a parent of B, and B is a parent of C. When you exclude B, then C is also excluded.

Importing Skin

Through the Import Mesh tool you can also import skins for your assets. However, it is a case of either/or: you either import the mesh or you import the skin.

The skins can be found in the Source tab:

Pic6: Skins in Source tab

Simply tick the box in front of the skin you want to import and click the Save button (or File -> Save) to import this skin.

Icon

You can only import one skin at a time.

Target View

The Target view shows the node hierarchy of the output *.cgf file. Here you see the effect of the Merge all nodes option.

Pic7: Target view

5. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesSee here.
Show selected nodeSee here.
Show selected subtreeSee here.

6. Display Options

View

OptionDescription
Show EdgesShows/hides Edges in the bottom half of the viewport when Show RC Mesh is enabled.
Show ProxiesIn Game viewport, shows proxy materials and proxy nodes in transparent blue.
Show SizeShows two boxes. The white one is the actual mesh bounding box. The grey one is a 1x1x1 cube to give some hint for the relative size of the mesh.
Show PivotsDraws a line from the center of a mesh bounding box to its origin. Makes it obvious if a cube, for example, is modeled around 0, or offset by some amount. Interesting if relative translation of meshes is off.
Viewport Mode
  • Game - Shows the final game mesh in the viewport.
  • Source - Fast-to-compute preview which does not involve the RC. It might give you a chance to debug the *.fbx file in case the RC fails an the console output is insufficient.
  • Game and Source - Opens both a Game and a Source viewport in the viewport area.
Show LODOnly useful if the *.cgf contains LODs (level of details). By setting this to N, it shows you what mesh the engine chooses for LOD N. When you have no LODs specified, then the mesh is the same for all levels.

 

For a description of the rest of the Display Options, click here.

7. Properties/Material Panel

This panel can either show the properties of the node selected in the Source view.

Properties Panel

Depending on whether the whole scene, a sub-tree or a single node is selected in the Node List, the following options appear:

Pic8: Properties panel

OptionDescription
Included in Export
  • Excluded - excludes the selected node or sub-tree from export.
  • Included - includes the selected node or sub-tree in the export.
Physics Proxy

Toggles some UDP options which only make sense for proxies.


Physical Options

OptionDescription
Jointed Breakable

This option only appears when non-mesh nodes are selected. When activated, the following options appear:

  • Gameplay Critical - Joints in the entire entity will break, even if jointed breaking is disabled overall. For example, if a level uses many breakable objects, but has disabled breaking (they don't want them to break), but they <do> want certain specific objects to break for gameplay reasons -- then only those objects with gameplay_critical will be breakable.
  • Player Can Break - Joints in the entire breakable entity can be broken by the player bumping into them.
  • Limit - Limit is a general value for several different kind of forces applied to the joint. It contains a combination of the values below. 
    ATTENTION! - This value needs to be defined, otherwise the simulation will not work correctly. 
    Crysis Example values: 100 - 500 can be broken by a bullet; 10000 can be broken by the impact of a driving vehicle or a big explosion.
  • Bend - Maximum torque around an axis perpendicular to the normal.
  • Twist - Maximum torque around the normal.
  • Pull - Maximum force applied to the joint's 1st object against the joint normal (the parts are "pulled together" as a reaction to external forces pulling them apart).
  • Push - Maximum force applied to the joint's 1st object (i.e. the one whose name is listed first in the joint's name, or if the names were not specified, the object the joint's z axis points towards) along the joint normal; joint normal is the joint's z axis, so for this value to actually be "push apart" (as a reaction to external forces pressing the parts together), this axis must be directed inside the 1st object.
  • Shift - Maximum force in the direction perpendicular to normal.
  • Constraint Limit - Force limit for the newly created constraint, is checked when the constraint hits a rotation limit and is being pushed further.
  • Constraint Min Ang - Rotation limits for the constraint (the interpretation is the same as in standalone constraints). The default is no limits.
  • Constraint Max Ang - Rotation limits for the constraint (the interpretation is the same as in standalone constraints). The default is no limits.
  • Constraint Damping - Angular damping (default 0).
  • Constraint Collides - Whether the constraint parts will ignore collisions with each other (default 1).
MassMass defines the weight of an object based on real world physics in kg. mass=0 sets the object to "unmovable". 
This is used on your base piece that will never move, e.g: on the basement of a house for example or the sign pole which should not be movable and always stay in the original position. 

When used in brushes and Geom Entities, this is the remaining part's mass. When used in regular Entities, all parts masses are scaled so that their total mass gives the mass specified in the entity properties. 
CAUTION - You must either define this value or density to ensure the simulation is working correctly.
DensityThe engine automatically calculates the mass for an object based on the density and the bounding box of an object.  Can be used alternatively to mass.
No Hit RefinementDo not perform hit-refinement at the rendermesh level – only use the phys proxy's surface type (but decals/effects will still be projected back to the rendermesh). If this is used, then the rendermesh doesn't have to have a surface type assigned – only the phys proxy material(s) should have surface types. 
By default, hit-refinement on the rendermesh is always performed, unless this string is set. Another way of having more precise ray traces is to have a dedicated 'no-collide' or 'obstruct' proxy.
Dynamically BreakableThis is a special-case string for dynamically breakable meshes (i.e. glass) – this string flags the object as "dynamically breakable". 
However this string is not required on Glass, Trees, or Cloth, as these are already flagged automatically by the engine (through surface-type system). This should only be used on new types of dynamically-breakable meshes.
Spawn As EntityIf the render geometry properties include "entity", the object will not fade out after being disconnected from the main object.
PiecesInstead of disconnecting the piece when the joint is broken, it will instantly disappear spawning a particle effect depending on the surfacetype of the proxy.
Deformable
  • Stiffness - Resilience to bending and shearing (default 10).
  • Hardness - Resilience to stretching (default 10).
  • Max Stretch - If any edge is stretched more than that, it's length is re-enforced. max_stretch = 0.3 means stretched to 130% of its original length (or by 30% wrt to its original length). Default 0.01.
  • Max Impulse - Upper limit on all applied impulses. Default skeleton's mass*100.
  • Skin Distance - Sphere radius in skinning assignment. Default is the minimum of the main mesh's bounding box's dimensions.
  • Thickness - Sets the collision thickness for the skeleton. The skeleton collides as a cloth object, i.e. it has virtual spheres with this radius around each vertex, and it has less priority than the geometries it collides with (it'll un-project itself unconditionally from them). It collides with static and rigid body objects only. It will collide with parts of the same entity it belongs to, except the one it skins (this way it's possible to set up safety shells inside the object to prevent excessive deformations). Setting thickness to 0 disables all collisions.
  • Explosion Scale - Used to scale down the effect of explosions on the deformable. This lets you have visible deformations from bullet impacts, but without vastly distorting the object too far with explosions.
PrimitiveForce this proxy to be a primitive in the engine.
No Explosion OcclusionWill allow the force /damage of an explosion to penetrate through the physics proxy.


Custom Properties

OptionDescription
Custom

Here you can add UDPs as key=value pairs, just as in the DCC tools. You can add UDPs for which extra widgets are not or can't be provided (think of game-specific UDPs).

Node information

Both node and mesh information are mainly for debugging. They show transformations read from the *.fbx file.

Node transformations are typically the transformations set in the DCC tool and might be different from 0,0,0.

OptionDescription
TranslationShows the translation of the selected node in the source file.
RotationShows the rotation of the selected node in the source file.
Uniform ScaleShows the scale of the X, Y, and Z axis. If the scaling is the same on all three axis, we simplify the output and write a single value for "uniform scale" instead.  
Number of child meshesShows the number of child meshes the node has. Nodes may have more than one mesh attached. Internally, we merge them to a single mesh per node.
AttributesMainly for debugging. A list of node attributes we read from the FBX. Shows what type this node is (examples: Camera, Light, Mesh).

Mesh Information

Meshes might have their own transformations, which is an offset from their node, but this is usually 0,0,0.   Otherwise, same as "node information".

OptionDescription
TranslationShows the translation of the selected mesh in the source file.
RotationShows the rotation of the selected mesh in the mesh file.
Uniform ScaleShows the scale of the X, Y, and Z axis. If the scaling is the same on all three axis, we simplify the output and write a single value for "uniform scale" instead.
Number of trianglesNumber of triangles the selected mesh has.
Number of verticesNumber of vertices the selected mesh has.

Material Panel

The Material panel shows all the materials present in the source file. Each source material has a Sub-material ID, Physicalization setting and Color.

Pic9: Material panel

Icon
About materials: We call the materials in the *.fbx file source materials. These are the materials you set up in the DCC tool. The engine material is the one you create in the Sandbox material editor. The engine material may have sub-materials. Purpose of the material list is to map source materials to engine sub-materials. When you have a source material with name "HeadDiff" and you assign it sub-material id 2, you say "All the vertices using material HeadDiff should use the third sub-material of the engine material" because we start counting with id 0. (sub-material 0 is the first one).

Settings

OptionDescription
MaterialShows the material used in the scene. Each CGF has a reference to a single material. With this material picker you set the material of the output CGF.
Opens the Material Editor (only works if a material has been assigned)
Assigns a material to the scene.

Material List

The top half of the Material panel shows the materials used in the source scene.

ColumnDescription
Material name Shows the name of the material.
Sub-materialMaps a source material to a slot of the engine material that can be assigned in the Settings view. The Sub-material can be changed by clicking in the Sub-material column and choosing a sub-material from the drop-down menu that appears
PhysicalizationThe Physicalization setting is the same as in the DCC exporters. If you set the physicalization setting of a material, it also sets the same setting for all other materials with the same sub-material id.
NOTE: This setting can be changed the same way as the Sub-material: by clicking in the Physicalization column and choosing a sub-material from the drop-down menu that appears.
ColorThe Color of a source material is for previewing purposes only. Setting a source material color helps finding all vertices using this material in the preview viewport, but does not affect the color of the exported *.cgf file in any way.

Right-Click Menus

When right-clicking on the column headers (Material name, Sub-material, Physicalization, Color), you can choose to show or hide these columns.

When right-clicking on a material, you get the following options:

OptionDescription
Select meshes using this materialSelects nodes in the Node List that use the selected material.
Select sub-material colorLets you select the color shown in the viewport for the selected material.

Generate Material

Click on Generate material on the right hand side if you want to generate a material from the FBX. Alternatively, you can browse for an already created material.

Texture List

The Texture List underneath the Material List shows all the textures used in the source object. This panel has four columns: FilenameExistsTIF exists and RC Defaults.

ColumnDescription
Filename

Shows the filename of the textures used.

Type

Lets you choose the type of the texture (diffuse, bumpmap or specular). This essentially sets the preset setting for the RC when converting to CryTif.

Adding Auto Proxies

In the Mesh Importer, you can add proxy meshes to static meshes with only a few clicks. The shapes for the proxy meshes are automatically generated.

This is done in the Source tab in the bottom left corner. Simply right click on the Scene node or any of the sub-nodes and choose Add Auto Proxies.

Pic10: Adding auto proxies for an entire scene

When you've added these Auto Proxies, you'll see the render mesh that will be used to generate proxies from. If it has several components, you can select which ones you want to use by clicking on them (a component - also called an "island" - is a part of the mesh that's not connected to the rest; for scene proxies each node will be a separate component, but it's also possible for nodes to have sub-components based on mesh connectivity). If you remove some components from an auto-proxies node, you can add them to a new auto-proxies node by going to the parent's menu again and selecting "Add remaining proxies".

The proxies are generated by voxelizing the render mesh, locating parts of it that can be reasonably approximated by primitives, and building simplified meshes from the remaining voxels.

When selecting the Auto Proxies parent node in the Source tab, you'll see several buttons and tick boxes in the Properties panel:

Pic11: Auto Proxies - buttons in properties 

ButtonDescription (only active before the proxies have been generated)
Close HolesCloses holes on the mesh used for voxelization. Open holes can result in voxels "spilling" through them.
Reopen HolesReopens the holes closed with the Close Holes button.
AllSelects all components for generation.
NoneDe-selects all components.
GenerateGenerates the proxies for the components you have selected. New sub-nodes for every proxy mesh shape will now appear under the Auto Proxies parent node.
ResetRemoves all the generated proxies, letting you start the process again.
Source Mesh

Shows/hides the mesh of the source object. There are three degrees to which the source mesh can be shown:

  • Solid - Makes the source mesh appear solid.
  • Transparent - Makes the source mesh appear solid.
  • Hidden - Hides the source mesh completely.
Proxy Mesh

Shows/hides the generated proxy meshes. There are three degrees to which the proxy meshes can be shown:

  • Solid - Makes the proxy meshes appear solid.
  • Transparent - Makes the proxy meshes appear solid.
  • Hidden - Hides the proxy meshes completely.
 
Primitives

Shows/hides the generated primitive proxies. There are three degrees to which the generated primitive proxies can be shown:

  • Solid - Makes the generated primitive proxies appear solid.
  • Transparent - Makes the generated primitive proxies appear solid.
  • Hidden - Hides the generated primitive proxies completely.
Voxels

Shows/hides the source mesh voxelization. There are two degrees to which the source mesh voxelization can be shown:

  • Solid - Makes the source mesh voxelization appear solid.
  • Hidden - Hides the source mesh voxelization completely.
Icon
Showing the voxels will help you edit the proxy shape; you can click a voxel in the viewport and that point will be connected to the rest of the proxy mesh.

The final proxy of your asset will be based on the Proxy Mesh and the Primitives mentioned above. The Source Mesh only serves as a way to see if the proxy is similar to the object and the Voxels are only the base on which the rest is built, as well as helping you to edit the proxy shape (see above).

Deselecting Components

Before you Generate your auto proxies, you can deselect any components you don't want to include in the proxy. To do this, you simply click on them in the viewport. They will then appear transparent, meaning that they will not be generated:

Pic12: Deselecting components
 

Icon
If you have deselected some components, they can be re-added after generation by right clicking the Scene node and choosing Add Remaining Auto Proxies. A new group of nodes will then be created. Select the parent node of this new group and click Generate to generate the missing auto proxies.

Properties

When selecting the automatically generated proxies in the Source tab, you can get a variety of properties in the Properties panel. These are different depending on what kind of proxy you have selected.

Auto Proxies (parent, all sources)

PropertyDescription
Merge islandsSelects whether to build a separate voxelization for each island (component), or use a combined one.
Axis-aligned voxelsUse axis-aligned voxels or try to find the "best fitting" bounding box orientation.
Force single boxForces a single bounding box as the proxy.
Convex hullMake convex hull of the source mesh before voxelization.
Detect primitive surfacesDetect boxes and cylinders in the voxelization.
Detect primitive rodsDetect capsules and longer cylinders in the voxelization.
Voxel cell numberSets the voxelization resolution (along the longest dimension).
Mesh smoothing passesAmount of normal smoothing applied to voxels left approximating with meshes. More smoothing means simpler proxies, but can lead to losing too many details.
Advanced settings
Use in and max normals as mesh verticesCheck if proxy meshes lose too many important features.
Inflate primitivesSize inflation applied to detected primitives.
Inflate meshesSize inflation applied to detected meshes.
Minimal rod primitive volume efficiencyThreshold ratio of volume covered by voxels / total primitive volume. Primitive rods (long capsules and cylinders) with ratios lower than this are discarded.
Minimal surface primitive volume efficiencyThreshold ratio of volume covered by voxels / total primitive volume. Primitive surfaces (boxes and cylinders) with ratios lower than this are discarded.
Height/radius threshold for capsule/cylinder rodsRods with height/radius ration higher than this are set to be capsules.
Merge primitive surfaces threshold (in voxels)Merges initial surface approximation candidate areas within this distance.
Surface detection smoothing iterationsGenerally more iterations leads to fewer/larger surface primitives.
Surface flatness thresholdSets how flat a region should be to be considered a surface primitive candidate.
Surface alignment with mesh normal thresholdSets how closely the principal surface primitive alignment should coincide with the source mesh.
Rod candidates merge threshold (in voxels)Merges initial rod approximation candidate areas within this distance.
Rod candidates curvature thresholdBending limit for areas considered for rod approximation.
Inflate primitives for voxel removal (in cells)Once a primitive is detected, the voxels contained in it are removed. This parameter sets how much to inflate the primitive for voxel removal (it has to be removed at least a little to avoid stray voxel noise on the surface)
Primitives holes refill ratioSets how strongly to refill holes caused by primitive removal from the voxelization (larger values can lead to "bulging")
Required primitive exposed areaMinimal primitive area that should not be covered by other voxels.
Minimal surface primitive voxels numberMinimal amount of voxels in surface primitive candidate regions.
Minimal rod primitive voxels numberMinimal amount of voxels in rod primitive candidate regions.
Minimal mesh voxels numberMinimal amount of voxels in islands left for mesh approximation.
Refine voxels with source meshAlign proxy mesh vertices (based on voxels) with the source mesh. Generally recommended, unless the source mesh is too detailed or noisy.

 

If you select a generated proxy in the Source tab, you can set the submaterial index assigned to it and its Crytek proxy type (Solid/Obstruct/NoCollide). For primitives dimensions and orientation can be manually edited, and for meshes it's possible to click on individual voxels to trigger them being a proxy mesh vertex (initially only a small fraction of voxels are selected as vertices, based mainly on the "mesh smoothing passes" setting). Note that the latter doesn't require the corresponding mesh proxy to be selected.

Setting up FBX Skeleton Proxies and Ragdoll Limits

This feature enables the creation of physicalized characters through the FBX pipeline, which requires the specification of bone proxy geometries and bone ragdoll limits.

Setting Skeleton Proxies

From CRYENGINE 5.3, bones can be assigned in mesh nodes as proxies. This means that the FBX must already contain all the proxy geometries. The mesh nodes that are used as proxies are not required to conform to any hierarchy.

Icon

If you have followed the Max or Maya naming conventions (for example, a bone is named "Bone", its proxy has name "Bone phys" or "Bone_phys"), mesh nodes are automatically assigned to the bones.

Pic13: Process for setting up bone proxies

Setting Ragdoll Limits

The ragdoll limit's properties contains a matrix with 6 entries: each of the three axes X,Y, and Z; there can be a minimum and maximum constraint. The constraint values are relative to a bone's bind pose rotation (They are added to a bone's local transformation when written to .chr file).

The matrix contains four controls for each constraint. Besides a spinbox for the actual value, there are two buttons and a checkbox. The checkbox can be used to disable or enable a constraint. The left and right buttons are used to copy the constraint from and to the current pose, respectively.

A bone can be posed with the controls above the IK limits. This pose is mostly used for previewing only. The typical workflow for setting IK constraints is by posing a bone in an extreme position and then copying that pose to a constraint.


Pic14: Process for setting up Ragdoll limits

3. Settings View

In the Settings view, you'll find general settings and settings related to the conversion of your scene.

General settings

Setting
Description
Input filename

Name of the file that was imported.

Output filename

This is the file that will be overwritten when you click Save.
It's either the last file you saved with Save as... or the file that you have opened with Open CGF.

Static Mesh Settings

SettingDescription
Merge all nodes

Combines all meshes on the same LOD to a single mesh.

NOTE: this is a rendering optimization and does not affect the pivots of the meshes.

Scene origin

By default, the RC ignores the local transformations of root nodes, which means that their pivots are placed at the world origin and meshes are translated accordingly. When Scene origin is enabled, the local transformation is applied and root nodes keep their world space position.

Conversion Settings

The conversion settings control the scale and orientation of the CGF mesh. Use these settings for example if the coordinate system of the DCC tool used to create the source file is different from CRYENGINE's coordinate system (in Maya, Y = up instead of Z).

Setting
Description
UnitChanges the unit of measurement in the mesh.
ScaleChanges the scale of the object. 
ForwardChanges which axis points forward. 
UpChanges which axis points upward.

Output Settings

SettingDescription
Use 32bit precisionIf enabled, vertex coordinates are stored with 32bit precision. If not enabled, they will be stored with 16bit precision.
  • No labels