Skip to end of metadata
Go to start of metadata

Overview

The Level Explorer enables you to quickly search for objects, hide/unhide and freeze/unfreeze objects in a list view. You can also browse through hidden or frozen objects without changing their state.

Icon

An object that is selected in the Viewport will be marked blue in the Level Explorer:

Pic1: Object selected

Double-clicking on it in the Level Explorer will focus the Viewport camera on it in the level.

Additionally, you can add layers in which you can group objects, so you can hide/unhide and freeze/unfreeze specific groups of objects at once.
This functionality can be used for numerous purposes; you might want to load one layer with certain objects at a certain point in your game, for example, and another complete layer of objects a little later. Also, layers can be used to make sure several people don't work on the same objects at the same time by hiding the layer they're not supposed to work on.
Another use for layers is when you want to replace a large group of objects etc. for another group of objects after something happens in your game.  E.g. you could have a village destroyed in a cinematic. In that case, you could have a layer with the village intact to use before the cinematic and a layer with the village when it's destroyed to use when the cinematic has been played.

The Level Explorer is shown in the bottom-left corner of the Sandbox interface by default, but can also be found in Tools -> Level Editor -> Level Explorer.

Menu Bar

The Level Explorer has its own menu bar with options. In this menu you can find the following options:

File

Menu ItemDescription
New LayerCreates a new Layer in the Level Explorer. (NOTE: these are only visible in the list below when you have chosen View -> Show Layers.)
New FolderCreates a new folder in the Level Explorer. (NOTE: these are only visible in the list below when you have chosen View -> Show Layers.)
Import LayerImports a layer. 

Edit

Menu ItemDescription
DeleteDelete the selected object(s)/layer(s)/folders. (NOTE: when deleting separate objects while View -> Show All Objects is active, the object(s) will be deleted without a warning dialog.)
Find...Lets you search for objects in the level by using the Search bar in the Level Explorer.
Freeze read-only layers
Freeze all layers that have been set to read-only on disk. This is particularly useful if you are using Perforce for version control, as only the layers you have checked-out (marked for editing) will be writable. In essence, you will only be able to modify what you can modify.

View

Menu ItemDescription
Show All ObjectsShows all objects in the level in a list.
Show Layers
Shows all layers and folders in a list without showing all the objects within them.
Show Full Hierarchy
Shows all layers and folders including all the objects within them.
Show Active Layer Contents
Shows the contents of the layer that has been set as the active layer.
Show Active Layer Label

When Show Layers or Show Full Hierarchy is active, displays the name of the active layer in the top-right corner of the Level Explorer:

Pic2: Active Layer displayed

Clicking the magnifying glass next to this name will select the layer in the list. This is especially useful when using a large number of layers.

Sync SelectionWhen enabled, syncs the selection in the Level Explorer with the selection in the Viewport; whatever is selected in the Level Explorer is always selected in the Viewport as well, and vice versa.

The Table View

You can press the heading of the column to sort the dataset, based on the alphabetic order in this column.

To show other columns, right-click the heading bar and choose which column to hide/unhide:

The three most-used columns are in the main context menu that appears:

Pic3: Column header context menu

ColumnDescription
VisibleShows the visibility state of the object. By clicking this icon  next to the object, you can choose whether an object or layer is visible or not.
FrozenShows whether an object or layer is frozen or not. An arrow with a line through it is frozen, an arrow without a line is not.
As with the visibility state, you can click this icon to choose if you want an object to be frozen or not.
NameShows the names of the objects.

Which sub-menu is shown depends on whether you have chosen to Show All Objects, Layers or the Full Hierarchy.

When Showing All Objects Is Active

Available Column
Description
LayerDisplays the visible layer to which the object is assigned; objects on invisible layers will not be displayed.
Object Type
Shows the type of the objects, e.g. Entity, Brush, Prefab, etc.
TypeShows the type of the objects. This is a different type to Object Type, as it's a modifiable string and could potentially be anything you want. This makes it a less useful column when filtering objects.
Default MaterialShows the path to the object's default material.
Custom MaterialShows the path to the custom material assigned on top of the object's default material, if defined.
BreakableShows what type of breakability the object supports.
Smart ObjectShows whether the object is a Smart Object or not.
Flow GraphShows which Flowgraph the object is used in.
GeometryShows the path to the object's geometry, if applicable.
InstancesShows how many times the object is used in the level.
LOD count
Shows how many LODs the object has.
SpecShows which MinSpec level the object is set to display on.
AI GroupIDDisplays the Group ID number associated with an AI character.

When Show Layers Is Active

Available Column
Description
ExportableShows if the layer is exportable. 
Exportable to Pak
Shows if the layer is exportable to a .pak file. 
Loaded in Game
Shows if the layer is loaded in the game. Choosing not to load a layer right away will improve performance.
Has Physics
Turns on the physics of physicalized objects in the layer.
PlatformShows which platforms the layer is shown on.

When Show Full Hierarchy Is Active

When this is active, all objects, layers, groups etc. will be displayed in a tree view, depending on how the objects are organized. All options for Objects and Layers will be available. 

Icon

The Level Explorer in the default interface is set to Show Full Hierarchy by default.

Pressing Ctrl+F opens a new Level Explorer window which is set to Show Objects. This window can be used as a quick way to look for objects.
It can also be configured in the same way the default Level Explorer can be configured.

Use the Search Bar under the Menu Bar to quickly filter objects by name. For example, enter "vil" to display all the objects containing these three characters: village_hut, anvil, villager, man_evil_01, etc. 

Filter

By clicking the Filter button next to the Search bar you can filter the objects by the properties in the context menus mentioned above under The Table View.

Icon

When there is a filter that is active, the Filter button will be blue.

As above, the filters change depending on whether you have chosen to Show All Objects, Show Layers or Show Full Hierarchy.

Context Menus

Objects

Right-clicking on an object will open the same context menu as when right-clicking on it in the Viewport.

Also, double-clicking on an object in the Level Explorer will focus the camera on it in the Viewport.

Layers

OptionDescription
Set As Active Layer
Sets the selected layer as the active layer.
ReloadReloads the selected layer.
Freeze read-only layers
Freezes all read-only layers.
Freeze all other layers
Freezes all layers except the selected one. 
Toggle hide all other layers
Hides/unhides all other layers.
VisibleChanges the visibility state of the selected layer.
FrozenChanges the visibility state of the selected layer.
Advanced

Color marks the selected layer with a color in the list.

Exportable determines if the layer is exportable or not.

Exportable to Pak determines if the layer is exportable to .pak format or not.

Loaded in Game shows if a layer is loaded in the game or not. 

Has Physics turns the physics of physicalized objects in the layer on or off.

Platforms makes the selected layer available for certain platforms or not. 

Open Containing Folder
Opens the folder where this layer is saved on your system.
Copy Filename
Copies the filename of the layer onto the clipboard.
Copy Full Path
Copies the full file path.
Source ControlSource control options depending on the source control system used.
RenameRename the selected layer.
DeleteDeletes the selected layer.
Icon
  • Double-clicking on a layer will make this layer the active layer in which objects you place in the level will be put.
  • Every layer is saved in a physically separate file on your hard-disk (example for the 'woodlands' level: <GameSDK Folder>\Assets\levels\singleplayer\woodland\layers)
  • Layers must be handled in source control separately.

Object Linking in the Level Explorer

Adding objects to a group and linking is possible through the Level Explorer.

  • If you drag an object onto a group or prefab, the object will be added to that group or prefab
  • If you drag an object onto a layer, it will be moved to that layer
  • If you drag an object onto another object, both objects will be linked
  • If both the dragged objects and the target are entity objects and the target entity has bones, then a menu will be displayed through which you can link to a bone or the object itself