Skip to end of metadata
Go to start of metadata

Overview

The Particle Editor can be found in Tools -> Particle Editor. The Particle Editor 2 uses a node based system that helps to better visualize particle dependencies. This visualization is very useful when creating second generation particles that are spawned out of first generation particles. The Particle Editor also enables the creation of GPU particles and the switching of CPU particles to GPU particles - this allows for a much greater level of physical interaction and many more particles on screen than was possible in the past.

 

1. The Menu Bar

In the menu bar, you have the following menus:

File

OptionDescription
NewOpens a new particle effect screen.
Open

Lets you open an existing particle asset.

Icon

As of release 5.4, you can also open particles through the Asset Browser. See this page for more information.

SaveSaves the current particle asset.
Save AsSaves the current particle asset under a different name.
Recent FilesShows a list of particle assets you have opened recently.
Reload EffectReloads the particle effect.
Show Effect OptionsOpens the Effect Options in the Inspector instead of the Properties. See Effect Options below for a more detailed explanation.
Load from Selected EntityLoads an effect from an entity selected in the Viewport.
Apply to Selected EntityApplies an effect to an entity selected in the Viewport.
Import Selected Pfx1 EffectImports an existing Pfx1 effect from the Particle Editor in the Database View tool directly into the Particle Editor 2 System.

Edit

OptionDescription
UndoUndoes the last action.
RedoRedoes a previously undone action.
CopyLets you copy a node.
PasteLets you paste a node.
DeleteLets you delete a node.

Window

OptionDescription
Add PaneLets you add the panes if you have previously closed them.
Reset layoutResets the layout, opening any closed panes where they were when first starting the Particle Editor.
Curve EditorActivates the Curve Editor pane.
Effect AssetActivates the Effect Asset pane.
InspectorActivates the Inspector pane.

2. The Toolbar

When initially opening the Particle Editor the Toolbar below will be displayed:

However, as soon as a New Effect button is selected, then the Toolbar expands (screenshot below) to include more user options. The full list of Toolbar options is shown in the table below:

ButtonDescription
SaveSaves an effect. The saved effects can be accessed through the Library.
Load from Selected EntityLoads an effect from an entity selected in the Viewport.
Apply to Selected EntityApplies an effect to an entity selected in the Viewport.
Import Selected Pfx1 EffectImports an existing Pfx1 effect from the Particle Editor in the Database View tool directly into the Particle Editor 2 System.
Reload EffectReloads the current open effect to its original state.
Show Effect OptionsOpens the Effect Options. See Effect Options below for a more detailed explanation.

3. Effect Asset Panel

Lets you create, edit or delete a particle effect.

Each component has the following options on the top:

ButtonNameDescription
NameBy double clicking, allows to edit the component's name.
EnableEnables the component. Disabled components are not processed by CRYENGINE, but still stored in memory. Used during production to experiment with different techniques.
VisibleMakes the component either visible or invisible. Particles in an invisible component are hidden, but are still simulated. Best used on parent components (for more information on parent-child relationships, please check SecondGen) that are not supposed to be visible (but need to be visible while editing).
SoloMakes every component in the effect invisible except for this one. Useful to isolate a single component for editing.

Navigating around the Editor Section is done by clicking and dragging the Middle Mouse Button.

Icon

You can move features in the component by dragging & dropping.

Context Menu

When right-clicking in the Effect Asset panel, you can add several pre-made components:

ComponentDescription
Advanced

Contains specific effect presets (fire, explosions, rain, etc.) with motion, timing and with most of the features that you may need to make these effects already included.

Most of the effects will work fine, but may need the addition of a texture and a tweak to the lighting.

There is also Advance:Default, a sort of starting node for a more complicated effects and with most features added (it’s faster to delete features that you do not need than to add features).

Default

The bare minimum setup presets (audio, sprites, GPU sprites, ribbon, etc).

These have no motion or timing elements and are not effect specific.

Parent

These are root nodes with no effects on the nodes themselves. They are used as the parent of other sub effects for timing or positional offsets.

Default

The component that is automatically created when a new effect is made.

4. Inspector

Depending on on the situation, the Inspector on the right can either show the Effect Options of the entire effect or the Properties of a selected component or attribute.

Effect Options

When the Effect Options are opened by clicking the respective button in the toolbar (see Toolbar above) you can add Attributes to the effect by clicking the button next to Attributes:

 

Each effect can have many different attributes that control certain aspects of the effect and allows it to efficiently connect with the game (for more information about how to use attributes in an effect please check Modifiers1).


Effects can have any number of custom attributes. Each attribute can have the following properties:

PropertyDescription
Type (1)

Specifies the type of attribute to be used:

  • Boolean: A Boolean value can be either true or false.
  • Integer: An integer is a whole number that can be either positive or negative.
  • Float: A floating point value data type.
  • Color: Allows adding a color value to the attribute.
Name (2)

Specifies a custom name to be used by the effect's modifiers.

Note: Names are case sensitive, please make sure you type the names correctly.

Default Value (3)

Sets a default value (based on type selected).

Scope

 Selects the scope that the value is associated to:

  • Per Emitter: Changing this value for an Emitter will affect that emitter only. Use this in conjunction with Flow Graph, Schematyc, game code or the Entity System to dynamically adapt each emitter to its external conditions.
  • Per Effect: Changing this value anywhere will modify behavior on every single emitter using this effect. Use this to change an effect's behavior on global game conditions. This value is global to this effect.
Use Min, Use MaxFor Integer and Float types, allows to clamp its input value to a maximum or minimum value.
Minimum Value, Maximum ValueWhen min or max are enabled, these are the values at which the attribute gets clamped.

 

Icon

Note: Types can be converted into each other. For example, if a Modifier expects an attribute of type float, but a color is assigned, then attribute is first converted into a float based on color brightness. If a Modifier is expecting a color Attribute, but a Boolean attribute is assigned, then the attribute returns either black or white.

Properties

When you add or select features in the component you can modify its properties using the Properties section. This allows you to create various effects for your particles. For detailed information on individual feature properties please refer to Wavicle Effect References.

5. Curve Editor

The Curve Editor can be used to tweak certain properties much in the same way that you can in the Environment Editor.

Icon

Note: Curves in Particle Editor 2 are not affected by the size of the handles (derivative weight). This is for performance reasons since these curves are to be evaluated for every particle every frame.

Icon

Holding Shift will let you move the keys horizontally or vertically in a straight line.

Functionality

Creating a New Particle

Creating a new particle now goes through the Asset Browser. Simply open the Asset Browser, browse to the folder you want to create the particle in, right click in the Search Results pane and choose Particle.

Opening and Saving a Particle

You can open a particle by either double clicking a particle asset in the Asset Browser or choosing File -> New in the Particle Editor.

Saving is achieved through File -> Save/Save As or the respective button on the toolbar in the Particle Editor.

Placing a Particle in the Level

Like other entities and objects, placing a particle in a level is achieved through the Asset Browser. Simply drag from the Asset Browser and drop into the Viewport.