Skip to end of metadata
Go to start of metadata

Animation

This will import the animations attached to the *.fbx file.

Pic1: Import Animation

1. Menu Bar

In the menu bar, there's one menu: the File menu.

File

OptionDescription
Open...Restores the FBX Importer dialog. This means the source *.fbx file is imported and the settings stored in the *.cgf file are applied. Works only with *.cgf files that have been written by the FBX Importer.
ImportImports a *.fbx, *.dxf, *.dae, *.obj or *.3ds file.
SaveOverwrites the current output file. (The current output file is the *.cgf file most recently written with Save as... or loaded with Open CGF). This option is disabled if no current output file exists.
Save As...Always shows a file dialog to specify the file path of the *.cgf file in the game folder. Also saves a copy of the source *.fbx (or other compatible) file to that same game folder, in which changes will be saved.

The FBX Importer will notify you if you attempt to overwrite a different *.fbx with the same filename this way.

2. Toolbar

The toolbar has the following buttons:

ButtonDescription
See above under File.
See above under File.

3. Clips/Root Motion Panel

Clips

Here you can decide which animations to import or even add animations. 

By clicking the button next to Animation clips, you can add new animations or remove all of the existing ones.

Removing a single animation clip is done by right-clicking on the number of the animation on the left and choosing Remove.

By clicking Preview this, you'll see the animation played out in the viewport.

Root Motion

By clicking Root motion, a node view appears. In this view you can optionally select a single node. if a node is selected, it acts as the ,"locomotion locator". see Setting up Locomotion Locator in 3ds Max.

4. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesShows all meshes.
Show selected nodeShows only the meshes belonging to the node selected in the node list.
Show selected subtreeShows only the meshes belonging to the subtree selected in the node list.

5. Display Options

In the top-right corner of the viewport is the Display Options button. Pressing this will open the Display Options menu.

This menu contains the following options:

View

OptionDescripiton
Joint namesShows/hides the names of the joints in the viewport.

Debug

OptionDescripiton
WireframeShows/hides the wireframe of the asset.
FramerateShows/hides the framerate in the viewports.

Camera

OptionDescription
Show Viewport OrientationShows an axis gizmo in the bottom-left corner of the viewports showing the orientation of the asset.
FOVChanges the Field of View. 
Near ClipA higher value means a larger distance of the near clipping plane to the camera. Increase this value if you experience depth buffer artifacts on objects further away from the camera. Decrease this value if objects appear to be cut off near the camera.
Move SpeedChanges the movement speed in left and right direction. Forward and back is always speed 0.7.
Rotation SpeedChanges the rotation speed of the camera.

Movement Smoothing

OptionDescription
Position

Basically "smears" translation of camera over time. Used to do smooth camera movements. A larger value means smoother transition over greater time span.

Rotation

Same as Position. Smoother camera rotations.

Grid

OptionDescription
Show GridShows/hides the grid.
Main ColorLets you change the color of the main grid lines.
Middle ColorLets you change the color of the middle grid lines.
SpacingChanges the distance between the grid lines.
Main LinesChanges the number of main grid lines.
Middle LinesChanges the number of middle grid lines.
OriginDraws a gizmo in the origin (position 0, 0, 0). Try it with an empty scene or wireframe mode to see the effect.

Lighting

OptionDescription
BrightnessChanges the brightness of the ambient light on the asset.
Ambient ColorChanges the color of the ambient light on the asset.
Rotate LightTurns continuous rotation of the directional light source on/off.
Light MultiplierUsed to dim or brighten the directional light.
Light Spec MultiplierChanges specular highlight on object from directional light.
Directional Light ColorSets the color of directional light.

Background

OptionDescription
Use GradientToggles between a gradient background and an evenly colored one.
Top ColorChanges the top color of the gradient background (if Use Gradient is unchecked, this will be the only color).
Bottom ColorChanges the bottom color of the gradient background.

Skeleton

This will import the skeleton attached to the *.fbx file.

Pic2: Import Skeleton

1. Menu Bar

In the menu bar, there's one menu: the File menu.

OptionDescription
Open...See here.
ImportSee here.
SaveSee here.
Save As...See here.

2. Toolbar

The toolbar has the following buttons:

3. Node List

In the Node List you can select which subtree or single node you want to import.

It also has a search bar at the top to quickly search for a specific node in case the asset has so many of them that it's hard to keep a good overview.

4. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesSee here.
Show selected nodeSee here.
Show selected subtreeSee here.

5. Display Options

See here.

Skin

This will import a skin attached to the *.fbx file.

In the original *.fbx file, more than one skin may have been created. With this importer, you only import one of them at a time.

Pic3: Import Skin

1. Menu Bar

In the menu bar, there's one menu: the File menu.

OptionDescription
Open...See here.
ImportSee here.
SaveSee here.
Save As...See here.

2. Toolbar

The toolbar has the following buttons:

3. Node List

In the Node List you can select which subtree or single node you want to import.

It also has a search bar at the top to quickly search for a specific node in case the asset has so many of them that it's hard to keep a good overview.

4. Viewport

Here you'll see the graphical representation of the animation you're importing. There's one dropdown menu in the top-left corner of this panel:

OptionDescription
Show all meshesSee here.
Show selected nodeSee here.
Show selected subtreeSee here.

5. Display Options

See here.

  • No labels