Skip to end of metadata
Go to start of metadata

Overview

This section will cover the basics of placing an object in the Editor, selecting and deselecting it, moving it around, as well as various other modifications that you can do to an object.

It will also cover some other useful functions of the Editor, to help arrange and manipulate the objects. Note that in the screenshots a finished environment is shown, with textures on the ground, other objects, and vegetation placed.

Please refer to the respective links for information on other level setup aspects.

Placing a Brush

Selecting the Move Mode and Follow Terrain Options

First, you need to do a little setup regarding how the object is placed in the level.

Click the Move Mode button (shortcut key = 1) so that you can move the object. You should also click the Follow Terrain & objects button so that when you drag the object about, it will slide along the terrain and objects.


The Move Mode and Follow Terrain buttons are selected, and therefore highlighted in orange.

Alternatively, Move Mode can be found in Edit -> Editing Mode -> Move.

Creating a Brush

To start with, you'll place a very simple object, called a Brush. To do this, open up the Objects tab of the RollupBar and click Brush:

Next, select the geometry of the object that you want to place. Let's use a tree as the object. Browse to the folder: Objects\Natural\Vegetation\Meadow\a_oak_tree_a

Dragging a Brush to the Main View

Move the mouse pointer to the name of the brush that you want in the brush browser and left click drag the Brush to the Perspective view .

In this case, you will drag a_oak_tree_a. Now, you should see something like this:

If you don't see something like the image above, don't worry. Go back to the previous step and make sure that the Move Mode and follow terrain & object buttons have been selected.

If you've accidentally lost the object or deselected it, hold down Ctrl and press Z to undo the last action. You may also need to adjust the Snap to Grid button so that the object does not appear underneath the terrain.

Snapping an Entity to the Ground

When you are in Move Mode, with an object selected, hold down Ctrl+Shift and click to snap the pivot point of the entity to anywhere on the terrain. This can be useful if you've dragged an object in that is lost under the terrain (but still selected) and you're already looking where you want it to be placed.

Also you can hold down Ctrl+Shift+Alt and click to snap the pivot point of the brush or entity to the ground and also align the object to the surface normal. An example of this would be snapping a tree, sideways, to the wall of a building.

Selecting and De-selecting Objects

Now that you have an object in view, let's deselect it, and then select it again. There are two easy ways of deselecting objects: press Esc when the object is selected, or click anywhere else in the view screen (be careful, however, not to click another object).

To select an object, move the mouse pointer over the object and click. Keep in mind that you can Show Pivots to make selecting objects more precise.

Deep Selection

As a new feature in CryENGINE 3.1.0, Deep Selection is now possible. This functionality allows users to easily pick and select the correct object among multiple objects at the almost same location.

Normally, the selection operation is the same as before. However, if you want to select an object in a crowded area, use "Deep Selection" with the specific key combinations. There are two deep selection modes, pop and cycling:

Selection

Key Input

Description

Pop Mode

Tab + Z + left mouse button

If there are multiple objects, then the second selection popup menu is shown.

Cycling Mode

Tab + left mouse button

Each click on the same position, cycles through valid candidates.

The deep selection mode is activated only when the multiple objects are in deep selection range.

The distance threshold value can be controlled in the Preferences menu under Deep Selection Range, found at: Menu -> Tools -> Preferences -> General Settings -> General -> Deep Selection -> Range. The default value is 1.

Selecting Multiple Objects

To select multiple objects, drag a box around the objects that you want to select, and then release the mouse button when all the required objects are inside the selection box.

Adding and Removing Multiple Objects from Selection

Hold down Ctrl and click either Remove or Add an object to your current selection, depending on whether it is already selected or not.

Modifying an Object

There are four different object manipulation controls: Select, Move, Rotate, and Scale.

You can select different object control modes by clicking the appropriate icon, or by pressing the 1, 2, 3, and 4 keys.

Alternatively, select the individual modes by using the Edit menu at the top of the screen.

  • Edit -> Editing Mode -> Select
  • Edit -> Editing Mode -> Move
  • Edit -> Editing Mode -> Rotate
  • Edit -> Editing Mode -> Scale

Select and Move Tool

Make sure that you're in the Move Mode. If you're not, select it.

Now, select the object, and you will see that it has X, Y, and Z selection bars, each corresponding to a different direction. The X bar is red, the Y bar is green, and the Z bar is blue. The bar on which you previously had the mouse pointer over, will be yellow.

If you move the mouse pointer to one of the bars, you can drag it back and forth in the direction it's pointing, along that axis.

You will notice that there is a square between each bar. Use this to drag along two different axes at once.

The Select and Move tool can also be accessed by using Edit -> Editing Mode -> Move.

The Gizmo will change shape according to what tool is selected.

Select and Rotate Tool

As with Move, you can rotate the object by using its control bars.

The Select and Rotate tool can also be accessed by using Edit -> Editing Mode -> Rotate.

Select and Scale Tool

This tool allows you to increase the size of an object, along its different axes.

The Select and Scale tool can also be accessed by using Edit -> Editing Mode -> Scale.

Clone

Select the object by clicking it, and then hold down Ctrl+C. Move the mouse pointer to where you want the copy of the object to be, and then click.

You can also copy an object by going to the menu bar at the top of the screen: Edit -> Clone.

Undo and Redo

At the top left of the Editor, you'll notice two icons with arrows. These are the Undo and Redo commands. Clicking Undo will revert the previous Editor action, and after the undo action has been performed, Redo will perform the action that you just un-did.

Also accessed by:

  • Edit -> Undo (Ctrl+Z)
  • Edit -> Redo (Ctrl+Shift+Z)

Advanced Object Manipulation

Axis Restraints

There are four axis restraint buttons. When dragging an object, each icon restrains the object to move in only the direction that you select. Clicking a different axis of the object will change the restraint.

Also accessed by:

  • Edit -> Constrain -> Constrain to X Axis
  • Edit -> Constrain -> Constrain to Y Axis
  • Edit -> Constrain -> Constrain to Z Axis
  • Edit -> Constrain -> Constrain to XY Plane

Snap to Terrain and Snap to Terrain and Objects

The Terrain Snap and Terrain & object Snap commands make sure that the objects move along the ground correctly. Terrain Snap will snap only to the terrain itself. Terrain & object Snap will also move the objects along any other objects on the ground.

Please note that this will not affect the rotation of the object at all. It will snap the object to the floor, at its axis point.

Also accessed by:

  • Edit -> Constrain -> Constrain to Terrain/Geometry

Snap to Grid

Click the button below once to turn Snap to Grid on. This will make sure that any objects you move, move only in specified steps.

Also accessed by:

  • Display -> Snap to Grid

The small arrow directly next to the Main Movement Snap button will display a drop-down list, which can be used to select the size of the grid to use to align against.

Click Setup Grid:

Snap to Angle

As with Snap to Grid, Snap Angle will cause the objects to snap and rotate by the predefined, set amount.

The small arrow directly next to the Main Rotation Snap button will display a drop-down list, which can be used to select the angle to rotate by.

Also accessed by:

  • Display -> Snap Angle.

Go to Object and Align Selection

To use the Go to Selected Object option, select the object that you want to go to and click the Go to Selected Object button, and then the Perspective view window will center on the object that you have selected.

To use the Align Selection option, select an object, click the Align Selection button, and then click the destination object. All transformations (position, rotation, scale) will be copied from the destination object to the selected object. Holding Shift when clicking on the destination object will result in only the position and rotation being applied to the selected object.

To use the Align Object to the Surface Normal option, select an object, click the Align Object to Surface Normal button, then click and drag the select object to the new location, this object will be automatically aligned to the surface normal of the terrain. Using Ctrl while dragging an object will align the object to the surface normal of the terrain or entities placed on the terrain such as roads and brushes. You can also use Ctrl+Shift and click to snap an object instantly into position. Press escape to exit the tool when your finished.

The Go to Selected Object, Align Selection, Align Object to Grid, Set Object(s) Height, and the Align Object to the Surface Normal buttons:

Also accessed by:

  • Modify -> Go to Selection
  • Modify -> Align/Snap -> Align to Object

Object Lock and Object Positional Controls

At the bottom of the screen, you'll see several other controls.

Lock Selection will not allow you to deselect the current object. You can turn this off again by re-clicking the button or pressing Escape.

The object position controls allow you to move an object to an exact position in the level by using the type in dialog boxes. Also, fine tuning an object's position can be done by using the up and down arrows to the right of each dialog box.

Also accessed by:

  • Edit -> Lock Selection

Selecting Sub-objects

On the Main Menu Bar, select Edit and then Sub Object Mode. From this menu, you can select the following sub-object selection tools:

  • Vertex: Enables you to click a corner point of your shape and reshape and resize using the Select and Move tool.
  • Edge: Select an edge to modify or move it.
  • Face: Enables you to click a face of your shape and reshape by using the Select and Move tool.
  • Polygon: Allows you to see the polygons of an object.

Although you can manipulate brushes with these tools, the changes are not saved. These are mainly for editing solids.