Skip to end of metadata
Go to start of metadata
Icon

UV Mapping Editor will be available from 3.8.3

Overview

The UV Mapping Editor is designed to provide easy and powerful ways to define UV's of a designer object like one built in Maya, 3D Max or Blender etc.


(This designer object has been converted from the Brush or Geom entity by Modify >Convert > To Designer Object)

Basic Unwrapping Workflow

  • Select a designer object
  • Go to SU > UV Mapping in the designer panel
  • Open a UV Mapping Editor window by hitting Open UV Mapping Editor on the UV Mapping panel
  • Select the polygons you want to unwrap in the 3D Viewport
  • Click a button from Plane, Cube, View, Sphere or Cylinder on the UV Mapping Editor to unwrap the selected polygons
  • Check the result output in the UV Mapping Editor

Controls

Mouse

LMBSelection, Transform, Manipulation etc.
Scroll wheelCamera Zoom In/Out
MMBPans a camera

Keyboard

1Translation Gizmo
2Rotation Gizmo
3Scale Gizmo
ZMove camera to look at the Selected Elements
W,A,S,DCamera navigation
CTRL+ZUndo
CTRL+SHIFT+ZRedo
DelUnmap
CTRL+ASelect All/None
F5Refresh all UV islands to remove unused ones

Opening the UV Mapping Editor

1. By selecting a menu item: View -> Open View Pane -> UV Mapping

2. By clicking the Open UV Mapping Window button in UV Mapping tool panel

  • Select or create a designer object
  • Navigate to SU group in the designer panel
  • Select UV Mapping
  • Click Open UV Mapping Editor

Unwrapping Functions

Basically polygons in a designer object have to be manually unwrapped to give them UV coordinates. To do that first select the polygons that you want to unwrap and select from Plane, Cube, Sphere, Cylinder or View buttons in the UV Mapping Editor. The selected polygons will be wrapped to the UV mapping view and the current sub material ID will be assigned to them.
(The buttons Plane, Cube, Sphere, Cylinder and View have been moved (from release 3.8.4) into the UV Mapping Editor they were previously in the UV mapping panel)

Plane

A plane projection whose normal direction is determined by one among the X, Y, Z and the average direction of the selected polygons is used to unwrap polygons.

First, select the desired polygons.

Click Plane after selecting the projection direction - you can select the projection direction with the combo box next to Plane button.

If you select multiple polygon groups that are separated from one another, then UV islands (as many as the selected polygon groups) will be created as shown below.

3 polygon groups create 3 UV islands

Cube

A projected direction, of each selected polygon will be determined by the closest direction among Up(0,0,1), Down(0,0,-1), Left(-1,0,0), Right(1,0,0), Forward(0,1,0) and Back(0,-1,0). If a normal direction of a polygon is directed toward (0.4082,0.4082,0.8164), then the polygon will be projected toward the Up direction.

View

All selected polygons will be projected to a plane whose normal direction is in the camera's viewing direction.

Sphere

UV's will be determined by spherical coordinates.

Cylinder

UV's will be determined by cylindrical coordinates.

Manipulation Functions

Pivot Type

There are two types of pivot. One is a pivot from selected elements, the other is the UV cursor which looks like this

You can select either pivot types from the the pivot combo box.

Sub Material

All sub materials of the main material used in the selected designer object will be listed in the combo box. What is selected here is synchronized to sub material combo box in the SU panel and vice versa.

Rotate Camera

Every time you hit this button the camera will be rotated by 90 degrees.

View All

If this is checked, all UV islands will be displayed all the time.

Island/Polygon/Edge/Vertex

An element represents either an Island/Polygon/Edge/Vertex.

You can select elements by clicking LMB or drawing a rectangle by dragging the mouse holding LMB. Holding down CTRL and selecting multiple elements while keeping the exiting selections is also possible.

The selected elements are represented in orange while the corresponding elements are represented in blue as shown below.

The selected elements can be transformed by manipulating a gizmo or by dragging the mouse. A gizmo can be switched from translation to scale through rotation by pressing the 12 or 3 buttons or by selecting an icon from the toolbar.

The pivot position is determined by either the center of the selected elements or the UV cursor position. This is set through the Pivot Type combo box on the toolbar.

Select Shared

If you want to select blue elements which are the corresponding elements to the selected elements, hit this button. See below pictures.

Loop Selection (available from 3.8.4)

This tool was previously known as Border Selection. The new Loop Selection in the UV Mapping Editor covers both border edges and inside edges just like the Loop tool in the Modeling Tool.

Border edge selected (Left screenshot: input selection, Right screenshot: result of Loop Selection)

Inside edge selected (Left screenshot: input selection, Right screenshot: result of Loop Selection)



Multiple edges selected (Left screenshot: input selections, Right screenshot: result of Loop Selection)

Unmap

Removes UV polygons from the UV Mapping Editor. When polygons are unmapped UV's of them will be generated automatically and based on positions. Note: the normals and the unmapped polygons are no longer displayed in the UV Mapping Editor view.

Sew

Attaches the first selected edge border along the second selected border edges, but does not move the island belonging to the selected edges.

Move and Sew

Moves the island belonging to the first selected border edges to orient them to the second border and attaches the first border to the second border.

Smart Sew (Available From 3.8.4)

Four steps are usually required to sew edges to other corresponding edges

  • Step 1: Select an edge
  • Step 2: Click Loop Selection (formerly known as Border Selection)
  • Step 3: Click Select Shared
  • Step 4: Click Move and Sew

This is a time consuming process i.e having to repeat these steps every time you want to sew edges together, hence SmartSew has been introduced to make the process much easier and faster.

  1. An edge is selected (orange edge in screenshot below) Loop Selection, Select Shared and Move and Sew are run sequentially. The corresponding edge is highlighted in blue (screenshot below



    Click SmartSew and the the two UV islands will be merged into one UV island

  2. Multiple edges selected (orange color edges) (Select Shared and Move and Sew are run sequentially). The corresponding edges are highlighted in blue



    Click SmartSew and the two UV islands are merged into one UV island

Separate

Separates the selected UV polygons from an island to which they belong.

The first screenshot below shows an island that has been selected. The second screenshot shows some selected UV polygons from the island. Selecting Separate will then separate out the selected UV polygons and they become an another island (third screenshot).

  

Flip Hori/Vert

Flips the selected elements horizontally or vertically over a pivot position.


Original


Left: Horizontal Flip. Right: Vertical Flip.

Alignment

Aligns the selected UV positions along an X or Y axis. The axis with the longest length of a bound rectangle (of the selected elements) is used for alignment.

 
Alignment with X axis

 
Alignment with Y axis

Screenshots

(The below designer objects have been converted from the Brush or Geom entity by Modify >Convert > To Designer Object)

  • No labels