Skip to end of metadata
Go to start of metadata

General:

Question:I believe something within the WAF system has gone wrong
Reason:One of the caches of the WAF system might be corrupt
Solution:
  1. As a first step you can force WAF to re-configure itself. Run the cry_waf configure command.
  2. If this still fails you can clear the the <SDK_DIR>/BinTemp/c4che direktory and run cry_waf again.
  3. If this still fails you might consider deleting the whole folder <SDK_DIR>/BinTemp and run cry_waf again.

Don't forget to report the bug with repro steps if possible!

Linux:

Question:When executing WAF I am presented with the command-line interface when expecting the GUI
Reason:
  1. cry_waf was executed with --console-mode=True
  2. Your Python 2.7 solution does not have TKinter installed.
Solution:
  1. Execute cry_waf with --console-mode=False
  2. Install TKinter on your system
      e.g. Ubuntu: sudo apt-get install python-tk

Visual Studio:

Question:Visual Studio Solution Manager selects Win32 for each project when selection Durango/Orbis.
Reason:

You are compiling with option auto_detect_compiler = False without having the Durango and/or Orbis SDK installed.

MSBUILD requires a folder for the Platform.

Solution:

Create missing MSBUILD platform folders:

Example VS 2012:
Default path: C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Platforms

Create empty folder: C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Platforms\Durango
Create empty folder: C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Platforms\ORBIS

Question:Visual Studio fails to Deploy & Run on Durango.
Reason:The Visual Studio Durango plugin needs to be specifically told to deploy on first time run for the given Configuration i.e. Debug, Profile,... .
Once completed you can hit F5 to deploy & run.
Solution:In the VS Solution Explorer Right-Click-> DurangoLaucher Project -> Deploy.
Consecutive debugging runs can be started using Build Solution (F7) and Start Debugging (F5).
  • No labels