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Course Setup

Installing CRYENGINE and GameSDK
This course requires CRYENGINE 5.5 or higher with GameSDK from the 
CRYENGINE marketplace. Here are the steps to install them:

1. Download and install the free CRYENGINE Launcher from here by click-
ing on the Download button. Note that you will need to create a free 
CRYENGINE account if you don’t already have one. If you need additional 
help with this, refer to our Installation Quick Start guide.

1. Start the Launcher and sign in to your CRYENGINE account.
2. In the Launcher, click on Marketplace > Marketplace. Search for “GameS-

DK” and add the asset to your cart. Make sure you add the latest version, not 
an archived version.

3. Check out and download the asset from the marketplace.
4. In the Launcher, click on Library > My Assets. Click on the arrow next to 

your GameSDK asset and choose Reveal in Explorer. You’ll be in a folder 
called gamesdk_#.# (where #.# is the software version number) . Open the 
GameSDK folder inside this.

5. Back in the Launcher, click on Library > My Projects. Click on the Import 
button. (GameSDK is a complete project, not just an asset, so it needs to be 
imported as a project.) Browse to the same gamesdk_#.# > GameSDK fold-
er you’ve already opened (not the deepest level GameSDK folder). Click OK 
to import your GameSDK project into the Launcher.

Opening the GameSDK Project
Click on the GameSDK project from the Launcher to open the project. 

Once you’ve launched the CRYENGINE editor, you need to tell it to scan all of your 
project folders so it becomes aware of the GameSDK assets that you just added. Find 
the Asset Browser tool (if it isn’t visible, enable it from the Tools > Asset Browser 
menu). In the Asset Browser menu, choose Edit > Generate/Repair All Metadata. 
Wait until all of the messages in the top right corner of the screen have disappeared 
before continuing. The Asset Browser generates a .cryasset file for every asset in 
your folders. These are required by the asset management system. After this is done, 
restart CRYENGINE.

Course Learning Objectives
Upon completion of this course, students will know how to:

•	 Navigate the CRYENGINE interface, Editor, and tool set
•	 Arrange customize tool panels
•	 Work with Brush entities
•	 Create and edit materials and textures
•	 Sculpt, import, and paint terrain, including making roads
•	 Add and manage vegetation using the Vegetation Editor
•	 Use Soft Depth Blending to seamlessly blend entities into the terrain
•	 Use the Environment Editor and Level Settings to control sunlight, time of 

day, latitude and longitude, and procedural volumetric clouds
•	  Precisely position and modify objects using snap and alignment tools
•	 Use assets and functionality from the free GameSDK (Software Development 

Kit)

Course Workbook Conventions
To help you understand the text in this workbook, we have used the following for-
matting conventions:

Important concepts are highlighted in bold, or refer to something you can do or click 
on: a button, entity, menu item, etc.

Nested items in menus or tool panels are separated with the right caret character, 
e.g.: Tools > Level Editor > Create Object.

Concepts and goals are explained first, followed by the exact 
step by step instructions to achieve them. Tips about best 
practices look like this yellow box.

Introduction
Welcome to the CRYENGINE beginner’s guide!

We’re going to learn basic CRYENGINE concepts and get 
familiar with the sandbox editor by setting up a basic level with terrain, vegetation, 
and brush (non-moving) entities with which the default GameSDK player can inter-

Pro Tip:
This is a “pro tip” sug-
gesting best practices 
or informing you about 
something of particular 
importance.

https://www.cryengine.com/
http://docs.cryengine.com/display/CEMANUAL/1+-+Creating+an+Account
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act.

Prerequisites
This course assume zero prior experience with CRYENGINE or game development. 
You can also view the video tutorial of this course, which comprises just the introduc-
tion to our free extensive “flappy boid” beginner’s course, instead of or in conjunc-
tion with this course workbook. Our recommendation is that you watch the videos 
and consult the course book for additional clarification.

You will need to be comfortable navigating the Windows operating system, File Ex-
plorer, and using the mouse. Experience with 3D programs is helpful but not required. 
Dual monitors are also helpful given the number of tools used, but certainly not 
necessary.

http://video tutorial
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Introduction: Navigation and Tool Layouts
Once you have followed the previous instructions to install CRYENGINE and 
GameSDK, import the GameSDK project, and open it from the Launcher, the first 
thing you’ll see is the default tool set. What you won’t see yet is a 3D world, simply 
because you don’t yet have a level open. Opening a project is the first step; opening 
or creating a new level is our next step.

Before we create our first level, let’s take a moment to look at how we work with the 
tool panels. CRYENGINE provides many tools, all of which you’ll find in the Tools 
menu. Any tool panel, once visible, can be moved by dragging its title bar. As you’re 
dragging a tool panel, you’ll notice that a series of boxes appear to indicate where 
you can drop the tool to split an existing tool window horizontally or vertically, or 
the entire application window. The middle box will set the dragged tool as a tab in 
the window where you drop it.

Customizing the Tool Layout
Let’s add some tools that we’ll be using, and hide others we won’t need. Right-click 
on the Asset Browser and choose close. From the Tools menu, choose Level Editor 
> Level Settings. Make it a tabbed window along with Terrain Editor and Properties 
on the right side. Also make the Environment Editor and Flow Graph tools visible. 
Dock them along the bottom of the screen by splitting the entire application window 

horizontally. Your layout should look something like this screen shot.

If you have more than one monitor, you might want to use it just for a fullscreen 
Flow Graph/Environment Editor window in this course, as they each present a lot of 
information. (There are several other tools that are very large as well, so you will find 
additional monitors to be very useful.)

There are also many toolbars. Right-click on any toolbar (just below the main menu) 
to see them listed. Try enabling the Physics and View Mode toolbars and hiding the 
Layouts toolbar. Read about customizing toolbar buttons here.

Finally, let’s save your customized tool layout so you can always go back to it: from 
the menu, choose Layout > Save Lay-
out As… and give it a name.

You’ll find a complete description of 
every item in the main menu here.

Creating a New Level
Create a new level called “practice” 
through File > New. (Be sure to keep 
your levels in the levels folder.) Leave 
the settings at their defaults, as shown 
here. The heightmap is a grid of 
points, each with a specific height; this 
is used to generate the hills and valleys 

of your terrain, or to keep it flat if you prefer.

After a moment, your first new level will appear in the 
Perspective viewport  – a flat grid with the sky and 
sun above you, and the ocean surrounding you. You are 
viewing this world through the editor’s default camera (as 
opposed to cameras you’ll need to create for your players 
to use in the actual game).

Navigation in the Editor
By default, you’ll see many lines of white technical information displayed in the 
upper right corner of the Perspective viewport. The first set of numbers at the top are 
the current camera position (Pos) and rotation (Angl). The second button from the 
right toggles through these Display Info modes, including a “clean” view with no 

Pro Tip:
Do not use spaces or 
non-alphanumeric char-
acters in level names (or 
anything else); use under-
scores instead of spaces.

http://docs.cryengine.com/display/CEMANUAL/Asset+Browser
http://docs.cryengine.com/display/CEMANUAL/Customizing+ToolBars
http://docs.cryengine.com/display/CEMANUAL/Menu+Bar
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information overlay.

Navigation is simple and intuitive:

To look around without moving, drag the right mouse button.

To actually move the default camera, use the WASD keys to move forward, left, 
backwards, and right respectively. You can also hold down two keys at the same time, 
for example W and A to move forward and to the left simultaneously. Use the right 
mouse button at the same time to control where you’re moving to. Add shift to move 
faster, or use the scroll wheel to change the camera speed while moving. To set the 
camera speed without having to move, click on the Camera menu at the top left of 
the Perspective viewport.

If you move past the terrain heightmap, you’ll see the ocean that’s hiding underneath 
it. You can control what is visible in the Editor, including the ocean and terrain itself 
using the Perspective Viewport’s Display menu.

Drag the middle mouse button to move straight up and down. (You can toggle 
Camera-Terrain Collisions - permission to go through the terrain - on or off in the 
Perspective Viewport’s Camera menu.)

Finally, you can jump to any position in your level using Level > Go To Position. 
(This can also include camera rotation.) All coordinates are in meters. Since your 
level is 1024x1024 meters, 512 on X and Y are dead center. Note that unlike some 3D 
modeling programs, CRYENGINE uses Z as the vertical axis.
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Introduction: Terrain and Environment
While many game worlds can be quite small or not bear any resemblance to the world 
we know, and therefore have no need of terrain, let’s learn how to give this flat terrain 
some hills and valleys. There are three ways to do this:

Generating Procedural Terrain
While game developers typically plan their terrain very 
carefully according to their Game Design Document 
and how they want to guide players through the level, 
you can have the engine generate procedural terrain, 
and either use it as-is or hand-sculpt it as the basis for 
your level:

From the Terrain Editor, choose File > Generate Ter-
rain. Read all about the effects these parameters have here. Suffice to say that modi-
fying these values will have a profound effect on the look of your terrain, generating 
everything from very gentle, featureless hills to near-vertical spikes and everything in 
between.

For now, accept the default values. You’ll end up with the mountainous island shown 
here. (Move your camera up and back to see the entire terrain.)

This terrain is to steep because the Generate Terrain tool automatically sets the max-

imum terrain height for a level 1024x1024m 
wide to 272m. The procedural terrain generator 
does this to generate consistent terrain models 
across most of the range of map sizes, from 
128m to 8192m. You can look up the exact 
heights set by this tool on this documentation 
page if you’re curious.

You can experiment with the settings in the 
Generate Terrain dialog. Let’s try making some 
gentle hills using the parameters shown here. 
The result is much more smooth, but the hills 
are still pretty steep from the perspective of a 
player walking around.

Let’s lower them: in the Terrain Editor, choose 
Edit > Reduce Range (Heavy). Each time you 
run this, the height of the terrain will get compressed downward, making your hills 
more gentle. Our example shows the original terrain and then after five applications 
of this filter.

Adjusting the Lighting
By default, a new level is essentially placed at Earth’s equator at high noon, which 
means that the sun is directly overhead.

In the Environment Editor, experiment with the North Pole–Equator–South Pole 
slider (i.e. latitude) and the time of day until you like the look. There is much, much 
more that the Environment Editor can do, but just changing these two values will 
have a profound impact on the sunlight in your level. We’ve used a latitude of 73 and 
a current time of 17:34.

Another setting that will make a big difference in the realism of your lighting is found 
in the Level Settings tool, which contains additional environmental settings. In the 
Env State section, there is a setting called Sun Shadows From Terrain, which is 
off by default. It controls whether the terrain casts shadows onto itself using the sun. 
Turning it on will prevent strange phenomena like your vehicle or vegetation casting 
shadows while the hill on which they’re sitting does not.

Lastly, as you place the sun at a more dramatic angle, the contrast in the lighting may 
get so high that you can’t see into the shadows. You can have the engine add reflect-
ed ambient light to your scene, called global illumination: in the Level Settings tool 

http://docs.cryengine.com/display/CEMANUAL/Terrain+Creation
http://docs.cryengine.com/display/CEMANUAL/Terrain+Editor
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under Total Illumination V2, enable Active. Reflected light will now lighten your 
shadows. Keep in mind that calculating global illumination is expensive in terms of 
computer resources and will typically cost you 20fps of performance.

Adding Clouds
CRYENGINE provides fully volumetric, procedurally generated 3D clouds that re 
affected by wind and the color of the sunlight. To enable them, you type a Console 
Variable (“CVar”) into the Console tool: r_VolumetricClouds 1. Console vari-
ables are a way to control the engine directly.

Voilà: clouds appear, whose properties you can explore and control through the Envi-
ronment Editor > Volumetric Clouds settings. For example, if you want the clouds 
to be affected by the wind, change the Wind influence parameter to a non-zero value.

Sculpting Terrain and Adding a River
We can also hand-sculpt terrain using the brush tools in the Sculpt panel of the Ter-
rain Editor. Let’s carve a winding canal or two through our landscape. While there 
is more than one way to accomplish this (including a spline-driven River entity and 
water bodies), an easy way is simply to lower the terrain so it’s below the height of 
the ocean, which is 16m by default. (You can set it as you like in the Terrain Editor 
under Edit > Set Ocean Height, including negative numbers.)

The Terrain Editor provides two tools that will work: Flatten evens out the terrain to 
a height you choose, creating flat areas. Raise/Lower can accomplish the same thing, 
but it changes the height of each heightmap point relative to its current position, 
whereas Flatten moves all point equally to an absolute Z position.

Let’s set our flatten tool to an Outside Radius of 25m and an Inside Radius of 22m 
to give its banks a somewhat gentle slope. (Making these equal will result in vertical 
banks – sheer cliffs.) Setting the Height to 12 means the river bottom will be 4m 
below the ocean’s surface. Use the Flatten tool to carve some winding rivers as you 
like through your level. Since we’re moving the heightmap below sea level, our canal 
will be flooded by the ocean automatically. To make wider, more gentle banks, as in a 
typical mouth of a river, increase the Outside Radius.

Smoothing the Terrain
You may have noticed that where you’ve used the Flatten tool, you have some jagged 
edges that don’t necessarily look realistic. The Smooth tool evens out differences in 

the heightmap. If you paint-
ed with it enough, you’d 
flatten your terrain. Use it 
selectively, and it’s a useful 
tool to get rid of unwanted 
artifacts and spikes like 
those shown here, before 
and after smoothing. Radi-
us is the size of your brush 
in meters, and Hardness 
is the strength of the brush 
stroke from zero to 100% 
(1). Try using it to make 
your steep edges more real-
istic, as we’ve done here.

Importing External 
Heightmaps
In addition to generating 
procedural terrain and 
sculpting it by hand, you can also import an external heightmap. You can read addi-
tional tutorials on how to import heightmaps created by third-party procedural terrain 
generation tools including World Machine. We are also adding tutorials on importing 
terrain data from World Creator and adapting real-world LIDAR or satellite data to 
an importable heightmap.

Let’s import the example heightmap provided with your course assets:

First, let’s control how high the highest point on the imported heightmap will be: 
from the Terrain Editor, choose Edit > Set Terrain Max Height and set it to 100m.

From the Terrain Editor, choose File > Import Heightmap. Browse to the Getting 
Started page in the CRYENGINE documentation or open the folder where you down-
loaded this course, and inside the sources folder, choose practice_heightmap_1K.
raw. You can take this heightmap and sculpt it further, or undo if you prefer to sculpt 
or import your own terrain. Save your level with Ctrl-S.

Seeing the Default GameSDK Setup
It’s useful to know what GameSDK actually is. GameSDK contains assets and func-

Terrain before and after smoothing

http://docs.cryengine.com/display/CEMANUAL/Terrain+Editor
http://docs.cryengine.com/pages/viewpage.action?pageId=25534772
http://docs.cryengine.com/display/CEMANUAL/Getting+Started+Guide+for+CRYENGINE
http://docs.cryengine.com/display/CEMANUAL/Getting+Started+Guide+for+CRYENGINE
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tionality from Crysis 2, a first person shooter game. This includes thousands of ob-
jects, materials, textures, particle effects, sounds, and functionality to help you learn 
the engine quickly using existing assets. Let’s see the player character that GameSDK 
provides:

Make sure your camera is close to the terrain somewhere (otherwise you’ll fall to the 
ground and die when the game begins!) and press Ctrl-G now to enter game play 
mode. You’ll immediately see your hands with a gun in front of you. You can move 
around with the standard WASD keys, shoot the gun (left mouse click on a PC), 
jump (spacebar), and toggle between 1st and 3rd person views by pressing F1, among 
other things. It’s crucial to test throughout the level design process to get a sense of 
scale relative to your player.

GameSDK gives you all of this functionality (and much more by default) to help you 
quickly create prototypes and learn the engine without facing the task of creating 
everything from scratch. However, if you plan to create all of your own assets and 
functionality, there is no reason for you to use the GameSDK project.

Texturing the Terrain
Our terrain is starting to get interesting, but it needs realistic surfaces. To accomplish 
that, we use the Paint tools in the Terrain Editor to add terrain layers. Terrain layers 
can be filtered by altitude and slope. Let’s begin by assigning a mud material to the 
Default layer to appear the lowest altitudes, including underwater:

Double click the Default layer and rename it “mud.” Click on the browse button next 
to Material and choose materials/terrain/mud_wet_grassy.mtl. Also, keep in mind 
that the texture is what you see at a distance - the general color of the terrain - and the 
material is the detail you see up close. Note that terrain paint layers must use terrain 
materials, which use a special terrain shader. Set the Min Height to 0, Max Height to 
20, Min Angle to 0, and Max Angle to 30. Click the swatch next to Filter Color and 
choose a nice dark brown muddy color. We’ve used HTML #6b6050. The filter color 
tints the material.

Make sure Mask by Altitude and Slope and Paint Layer ID are enabled. You can 
use the Paint brush to apply a terrain material selectively. However, if you just want 
to apply it to the entire level, right-click on the mud layer and choose Flood Layer. 
After a few seconds, you should have the mud and rocks texture everywhere up to 
25m on the heightmap on any surface up to a 30⁰ slope.

Right-click in the Paint window and create another layer called “grass.” Make the 
filter color a realistic green with a value of about 128. Set the other parameters as 

follows:

Min Height 30
Max Height 70
Min Angle 0
Max Angle 40
Material: materials/terrain/grass_4.mtl
Texture: textures/terrain/detail/grass_4_diff.dds

Again, right-click on the layer and choose Flood Layer. Note that a terrain layer 
Material provides the detail that is seen up close, whereas the Texture provides a 
rough approximation of the layer seen at a distance.

Let’s create a layer of dry sand between the wet mud and grass. Create a new layer 
called “sand” and set its parameters as follows:

Min Height 20
Max Height 30
Min Angle 0
Max Angle 30
Material: materials/terrain/sand_no_stones.mtl

Again, right-click on the layer and choose Flood Layer.

Lastly, let’s make our steep terrain rocky, like cliffs: create a new layer called “rock” 

The mud layer at the ocean’s edge
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and set its parameters as follows:

Min Height 0
Max Height 1024
Min Angle 40
Max Angle 89.989998
Material: materials/terrain/canyon_rock_terrain.mtl

Again, right-click on the layer and choose Flood Layer. Save your level.

Lastly, you must re-generate the terrain texture after modifying or adding paint layers: 
from the Terrain Editor’s File menu, choose Generate Terrain Texture. Accept the 
defaults and click OK. Save your level.

If you take a good look around, you’ll see that you have the basis of realistic terrain. 
However, this is just the beginning. Making believable terrain with mixed surfaces 
calls for additional textures and features on the landscape - vegetation, trees, bushes, 
rocks, and a fair amount of chaos and variety.
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Introduction: Adding Features to the Terrain
To have a truly realistic world, you’ll need to add vegetation and inconsistencies in 
the terrain. Before we add the big items, let’s use Decals to hide seams and repetition 
in the terrain materials.

Using Decals
Decals are small textures including an alpha channel (transparency), designed to be 
blended on top of other textures. They add realism and details and help hide tiling in 
textures used on large areas. In the example below, we’ve used materials/decals/dirt/
decal_burned_22 around the campfire to add a burned feeling to sand painted with a 
terrain layer.

Use Create Object > Misc > Decal to add one. In 
the toolbar, you’ll see four “gizmos,” any of which 
can be used to select entities and modify their po-
sition, orientation, and size: Select (4), Move (1), 
Rotate (2), and Scale (3). (Their keyboard shortcuts 
are in parentheses.)

Use the Move tool to select the decal. You’ll see 
three arrows, one for dragging the object along each 
of the three axes, as well as three dual-axis planes to 
drag an object along two of the three axes.

Drag the decal to whatever surface you want to apply it to until you see the red 
“Replace Me” symbol. Then click on the General > Material property in Properties 
and browse to Materials > Decals and find one you like. Adjust its position relative 
to the terrain or object surface to adjust blending opacity. You can also rotate a decal 
non-parallel to the surface to which it’s applied to make one edge softer than others.

The other aspect of blending decals into other textures is to check the Decal > Sort 
Priority parameter (0 - 255), which controls the order in which decals are rendered 
(i.e., what’s on top). Decals with higher numbers are above those with lower num-
bers. Decals are a very useful way to add variety to terrain, roads, floors; to stamp 
words onto walls or doors; to indicate damage dynamically, and much more.

Adding Grass
While you can always place individual .CGF models of trees, bushes, etc. on your 
terrain, the Vegetation Editor makes it far easier to populate your terrain with larger 
numbers of assets and to manage their properties.

Choose Tools > Vegetation Editor. Let’s start with some basic grass:

Click on the Add Group button (the leftmost button that has the trees with the + sign 
inside a box). Double click the new “Default1” layer and rename it “grass.”

Click the checkbox next to your group to make it visible, and click on the name to se-
lect it. Click on the Add Object (second) button – the trees with the + sign inside the 
circle. Browse to objects/natural/ground/grass_tall/bending_grass_normal_a.cgf.

Make sure your grass object is selected in the Object list, and set its properties as 
follows:

Size Var .3 Vary the size randomly by up to 30% (a recommended 
value)

Random Rotation  Enabled – helps hide the repetition of the same object

Align to Terrain Normals Enabled - akes vegetation sprout perpendicular to the 
terrain. Use with caution for realistic results.

Bending 0 Bending makes the vegetation bend from the force of the 
wind. Expensive for the engine, so use with discretion, 
usually on taller vegetation like trees or tall grass.

Density 4 The distance between objects

Elevation Min 30
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Elevation Max 70

Slope Min 0

Slope Max 70 (here we’ve matched the slope and altitude masking we 
set on the grass terrain layer)

Auto Merged  Enabled - best practice is to always use this for grass 
(and nothing else) to use a tiled approach to make grass 
rendering perform better.

Set your Brush radius and paint as you like on the terrain.

Adding Trees 
Next, let’s use another vegetation group to add some trees: Click on the Add Group 
button. Name your new group “trees.”

Click the checkbox next to your group to make it visible, and click on the name to 
select it. Click on the Add Object button. Browse to objects/natural/trees/aspen/b_
aspen_a.cgf. If you want to try adding additional versions of the aspen trees from 
this folder now, you can, but you will want to differentiate the density and potentially 
other parameters to keep it realistic.

Make sure your trees group is selected in the Object list, and set its properties as 
follows:

Size Var .3 Creates a 30% random variation in size (recommended)

Random Rotation  Enabled - helps hide repetition of same model

Align to Terrain Normals Disabled. In some case, as with grasses, you may want thi 
enabled for vegation that should grow perpendicular to 
the ground plane.

Bending 0 1 (so your trees move in the wind)

Density 35 Since these are large trees, we’ll put more space between 
them (remember units are in meters)

Elevation Min 30 Here our trees will start 14m above the default waterline 
of the ocean, leaving us some space for terrain typically 
found closer to the water, like a sandy beach.

Elevation Max 70 At some point, we might want to limit the maximum 
altitude of certain trees, and give way to those that grow 

on higher terrain, like non-deciduous evergreens.

Slope Min 0

Slope Max 30 It wouldn’t make sense for the big trees to grow on ex-
tremely steep hills.

Auto Merged  Disabled. Only relevant for assets set up to make use of 
this feature. Read this tutorial for detailed information.

Set your Brush radius and paint as you like on the terrain. If you overdo it, use the 
Erase brush.

Adding a Vehicle
GameSDK also provides several vehicles and the animations 
and functionality to allow the player character to drive them. 
Let’s add one of them:

Using the Create Object tool, select Legacy Entities > Vehi-
cles > HMMWV. You can either drag the entity onto the terrain or double-click it in 
Create Object and then click on the terrain to place it.

Since your terrain is not flat, let’s make it easy for your vehicle to stay parallel to the 
terrain surface, as if its mass kept it naturally on the ground: at the top right of the 
Perspective Viewport, click on the third button from the right. The menu shown in 
this graphic will appear. Enable 
both snapping to terrain and 
snapping to surface normal. 
When both are enabled, the icon 
will look as it does in the top row 
of this screen shot. Notice the sub-
tle difference in the orientation of 
the cube floating over the mountains in the icon: parallel to the terrain (i.e., snapping 
to terrain and surface normal enabled) or not (snapping to surface normal disabled, as 
shown in the second row in this screen shot). Now you can use the move tool to slide 
your vehicle along the terrain, and it will remain parallel to its surface. You can also 
select an entity and CTRL-SHIFT-click anywhere on the terrain to snap an object to 
that position without having to use terrain snapping.

Save your level and then use Ctrl-G to enter your game. Walk up to the driver’s door 
of your vehicle and press the F key to get into the driver’s seat. You can use F1 to 
switch between 1st and 3rd person perspective. Use the mouse to change the camera 

Pro Tip:
You can ctrl-click 
with the Vegetation 
Editor to place a 
single entity.

https://docs.cryengine.com/pages/viewpage.action?pageId=24285889
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position when in 3rd person view, and the WASD keys to drive. Spacebar will brake. 
Try driving around your level to get a feeling for its scale and bumpiness relative to 
the vehicle. Think about where you might want to place a road through the level.

You may also want to try the CRYENGINE speedboat, which you also add using 
Create Object > Legacy Entities > Vehicles. Place it in the water so the waterline is 
just below the red line around the edge of the boat. To drive it, wade into the water, 
swimming (you’ll find that your player character will automatically switch to swim-
ming mode when his feet can no longer touch the bottom) and once you’ve swum up 
next to the driver’s side of the boat, press the F key to get in, just as you do with other 
vehicles. WASD will drive and steer, but beware - this boat is fast!

If you try to drive the boat outside the edges of your terrain map size, you’ll quickly 
learn a memorable, fundamental fact about the engine when your boat flies into the 
air: physics are only fully enabled within the boundaries of your terrain height-
map - thus we refer to it as the playable terrain. You can add entities to decorate 
your world beyond your terrain boundaries, like mountains or buildings - as long as 
those entities don’t need to move or respond to physical forces.

You can use these and other vehicles, their associated animations and scripts in your 
own games by replacing the models and modifying the behavior scripts as desired.

Adding a Road
Let’s give your vehicle a road to drive on. While using the Road tool is pretty 
straightforward, building roads that are actually drivable takes a fair amount of plan-

ning and practice. A few general tips are to avoid sharp turns and steep inclines, to 
make it wider than you think you need to, and to break long road splines into shorter 
segments. Take a good look at your terrain and decide where a realistic road could be 
placed before starting.

As you’re about to see, the road tool can be used to alter the heightmap, carving 
canyons or raising the terrain up to meet it. Before you start drawing your road spline, 
find a place where a bridge can be placed to span the river you made. Also, it’s useful 
to turn on Snap to Terrain to insure that each point you place actually lands on the 
terrain.

First, we use the road tool to draw a spline curve: using the Create Object tool, 
choose Misc > Road. Each time you click on the terrain, a spline point is placed on 
the terrain. If you click and drag at the same time, you can manually control the cur-
vature at a point. Curvature cannot be adjusted after a point is created, although you 
can delete and add new points.

Don’t make the road too long, but break it into separate segments if necessary. When 
you get to the edge of your river, double click to make the final point.

Before you do anything else, go to the Properties window and set the desired Width 
of your road in meters. Try 8m. You’ll see the spline adjust its width.

Move your camera around and take a careful look at the points along your road. For 
ase of editing a road spline point by point, it’s often useful to turn off Snap to Ter-
rain and use the Move gizmo to move individual points.

Sometimes the fastest thing to do if your terrain is fairly flat is to use the Scale gizmo 
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to reduce the variation in the height of your road spline along the Z axis. You will 
also almost certainly want to click on the Edit button in the Properties window, select 
individual points and move them into more precise positions, delete those you don’t 
want or need to change, and Ctrl-click on the spline to add new ones. Don’t forget to 
click on the Edit button again to end spline editing once you’re done.

If you want to carve a road into the side of a mountain or steep hill, make sure the 
outer edge of your road spline is aligned with the surface of the hill, letting the inside 
edge disappear into the terrain. That way when you align the heightmap to the road 
surface, you’ll be digging into the terrain, which usu-
ally looks more realistic then building up steep terrain 
beneath the road. (For that, you may want to use a 
bridge of some kind instead of a road spline.) You 
can also vary the Angle of individual points to create 
banked turns.

Now let’s add a material to the road: with the road spline selected, go to the Gener-
al section in the Properties panel and click on the browse button next to Material. 
Browse to the GameSDK > materials > roads folder and pick something that inter-
ests you.

Now comes the dramatic part: with the road spline selected, click on the Align 
Height Map button in the Properties window. The terrain will be modified to follow 
the road spline, and the terrain painted with the road material. After this step, check 
your road carefully. You may want to undo the heightmap alignment, adjust individ-
ual points, and re-align. You can also vary the Angle property of individual points to 

create banked turns that are easier to drive at high speeds.

If you have vegetation growing on top of the road, you’ll also want to click on the 
Erase Vegetation button, adjusting the Border and Erase Veg Width parameters as 
desired. Making Erase Veg Width Var a non-zero value will add some more natural-
istic randomization to the edge of the vegetation (unless you’re creating a perfectly 
maintained lawn).

Note that the road and river tools essentially use the same kind of spline tool.

Adding Architectural Elements
Static objects that won’t move and with which the player cannot interact are called 
“brushes.” Since they don’t require physics calculations, they are very efficient for 
non-interactive entities. Keep in mind that they also can’t be controlled or animated 
through Flow Graph. Think of a brush as painting 3D objects. Let’s use them to add a 
house and some furniture:

Let’s add a house: make sure Snap to Terrain 
is enabled, but not Snap to Terrain Normals 
(assuming you want your floors to be level rather 
than leaning). Find or sculpt a nice flat spot by 
the water. From the Create Object tool, choose 
Brush. Browse to objects/architecture/build-
ings/fishing_houses/fishing_house_c.cgf.

If your house isn’t exactly where you want it, you can use the gizmos to move, rotate  
and scale it. You’ll notice that each tool represent the X, Y, and Z axes in a different 
color. The Rotate gizmo also has as a yellow line that lets you rotate freely about all 
axes simultaneously. The Move tool also provides planes that let you slide objects 
along two axes simultaneously, or you can drag any arrow to move an entity along a 
single axis.

You may find that you have vegetation growing through the floor of your house; if so, 
use the Vegetation Editor’s Erase brush to get rid of it.

Once you have your house in place, you can have 
some fun furnishing it by using Brush entities to 
place furniture and props that you’ll find in the 
GameSDK\objects folder. You’ll also find stone 
walls, fences, piers, bridges, and much more to 
bring your world to life. In this example, we’ve 

Pro Tip:
When editing individual points 
on a road or river spline, make 
sure your snap to terrain is off.

Pro Tip:
A fast way to add brushes is simply 
to drag meshes (.CGF files) directly 
from the Asset Browser into a level.

Pro Tip:
When you’re browsing for an 
asset, there is always a search 
box at the top of the browser. Try 

typing a word, like “chair”.
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added chairs, a table, refrigerator, and even a stuffed trophy for the wall of our cabin.

Also, as you’re placing an entity, you can use the scroll wheel on the mouse to rotate 
your entity as you’re placing it. Snapping to Angle (i.e., rotation) will affect this, 
whether on or off. Also, use Snap to Terrain (T) when you want objects to land on 
the ground, but turn it off and enable Snap To Geometry (O) if you want entities to 

land on existing objects, like when you’re placing a prop on a table.

Soft Depth Blending
One of the most useful features for integrating objects into the terrain believably is 
called Soft depth test. It blends objects into terrain materials to hide hard edges:

From the Tools menu, open the Material Editor.

From the Material Editor’s File menu, choose Choose Material From Scene and 
click on any terrain material in your level. (Under the eyedropper, you’ll see the ma-
terial name appear.)

The material will be opened for editing in the Material Editor.

Scroll to Shader Generation Params and enable Soft depth test.

Save your material in the Material Editor menu: File > Save.

If you look at the edges of objects placed on this terrain material, you’ll see a marked 

difference in the way they blend into the terrain. Like all such features, this has a 
performance cost, so use it only as needed.

Adding an Environment Probe
A simple way to improve the look of your lighting is to add an environment probe. 
Environment probes produce more accurate shadow colors, ambient diffuse values, 
and specular reflections. Probes also calculate reflected lighting from entities in your 
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level and factor them into the color of materials on nearby surfaces.

Every level should at least have a global environment probe that covers the entire 
level. You’ll probably find that you’ll want to add more localized ones to interiors and 
specific spaces.

A global environment probe should be placed at the horizontal center of the level 
with the bottom of the box below the terrain and top at least as high as eye level. The 
recommended settings for a global environment probe are as follows:

Box Size XYZ Large enough to cover the entire level

AttentuationMaxFalloff 0

IgnoreVisAreas True

SortPriority 0 

Use the Create Object tool to select Misc > Environment Probe. Place it in the 
middle of your level, and adjust its properties as detailed above. Environment probes 
are invisible to the player, as they have no mesh, so keep in mind that you size them 
using the Box Size X/Y/Z parameters, not Transform > Scale.

Note that if you change your level design, you should recalculate your environment 
probes by clicking on Cubemap > Generate > Cubemaps in the Properties win-
dow, as they are not dynamic.

Adding Weather
While plenty of games take place in very constrained, designed environments with 
no resemblance to the natural world, you can easily add realism and excitement to 
natural environments using the rain, snow, lightning, and even tornadoes (in addition 
to the wind built into the Environment Editor) that Game SDK provides.

Try adding the rain effect by using the Create Object tool > Legacy Entities > En-
vironment > Rain. Using the Properties window > Lua properties, you can affect 
the speedc, intensity, visibility (lighting), and more. You’ll notice that it’s not just a 
raindrops overlay; it also places puddles on the ground, splashes rain drops in those 
puddles in real-time, and makes existing materials look wet using animated decals.

Adding Life
The last thing that we’ll do is add some life to our terrain using animated animal 
assets from GameSDK:

Move to an area where you have beach terrain next to your river.

Using the Create Object tool, choose Legacy Entities > Boids > Frogs. Click at the 
water’s edge to place your frogs. They will start their froggy behavior immediately, 
avoiding you if you move near them. You can explore Properties that will affect their 
behavior including how many  frogs per entity and how far they can roam from the 
entity’s center. They will also go in and out of the water.

You’ll also find additional “boids” including seagulls, turtles, chickens, etc. with spe-
cific associated behaviors which you can use to quickly add life to your levels. You 
can even make them follow the player.

Summary
This completes our introduction to CRYENGINE fundamentals. You will be using the 
techniques covered in this brief tutorial in all of your future game designs.

Going Further
If you’re ready to learn how to build an actual working game, we suggest that you 
continue with our extensive free “flappy boid” course, which you can download from 
our Marketplace. We suggest that you watch the video tutorials of the course and refer 
to the course workbook for additional information, and to the high resolution screen 
shots included with the course that clarify the game mechanics and design.

http://Marketplace
http://video tutorials
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