Overview
The main menu is where you can access everything from basic file operations and display options, to more advanced features such as terrain and level
editing tools and AI settings.
Many of these commands can also be executed the ToolBar and also by using keyboard shortcuts.

Overview
The File Menu
The Edit Menu
The Modify Menu
The Display Menu
The Config Spec Menu
The Group Menu
The Prefabs Menu
The Terrain Menu
The Audio Menu
The Game Menu
The AI Menu
The Tools Menu
The View Menu
The Help Menu

The File Menu
The File menu includes commands related to the handling of files such as open and save level file, show log file, and a list of recently loaded levels.
Menu Item

Description

New

Please see Creating a New Level for information on creating a
new map.

Open...

Opens an existing level.

Save

Saves the level.

Save As...

Saves the level under a different name.

Save Modified External
Layers

This option allows you to save just the external layers which
have
been modified since last save.

Export to Engine

Exports the level data to the level.pak file so the level can be
played in
Launcher. See Preparing a Level for Playing for more
information.

Generate Terrain Texture

Generates the terrain surface texture in a compressed format
to the
terraintexture.pak file. This is required so that changes done
by the
terrain painter will be visible in the Launcher.
See Creating a New Level for more information.

Save Level Resources...

Saves all assets that are used in the level to a folder.

Export Selected Objects

Saves the selected geometry to an .obj or .fbx file.

Export Terrain Area

See Terrain Import and Export for more information.

Export Terrain Area with
Objects

See Terrain Import and Export for more information.

Export Occlusion Mesh
Show Log File

Shows the log file containing all text that was printed in the
console.
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Recent Files List

Lists recently opened levels.

Exit

Closes the Editor, prompting the user to save before exiting,
if changes are detected.

The Edit Menu
The Edit menu contains commands related to object manipulation and selection.
Menu Item

Description

Undo

Undoes the users last action (Ctrl+Z).

Redo

Redoes the users last action (Ctrl+Shift+Z).

Delete

Deletes the selected object(s), when you press the Yes button on the
confirmation window.

Clone

Duplicates the selected object (Ctrl+C).

Hide Selection

Hides the selected object (H).

Unhide All

Unhides all hidden objects (Ctrl+H), when you press the Yes button
on the confirmation window.

Freeze Selection

Freezes the selected objects (F) so they can no longer be moved or
selected.

Unfreeze All

Unfreezes all frozen objects (Ctrl+F), when you press the yes button on
the confirmation window.

Hold

Hold (save) the current state (Ctrl+Alt+H).

Fetch

Fetch (restore) the saved state (Ctrl+Alt+F).

Select All

Selects all visible, non-frozen objects.

Select None

Deselects objects currently selected.

Select Invert

Inverts the selection, so object currently not selected be come selected
and objects currently selected become deselected.

Select Objects

This will brings up the Select Objects Window.

Lock Selection

Having an object in lock mode prevents you from selecting other objects
(Ctrl+Shift+Space), until you press Escape.

Next Selection
Mask

Selects the next selection mask (masks can be specified in the field with
the
pull down icon in the editing toolbar - Named Selections).

Sub Object Mode

When an object is selected and using the edit mesh function, you have
the
option to select and edit various components of the geometry.

Editing Mode

Select the various object editing modes.

Constrain

Limits the movement to the X, Y, Z, or XY axes, to the surface of the
terrain,
or to the surface of the terrain and objects.

The Modify Menu
The Modify menu is where you will find commands used to modify and change attributes and properties such as height and alignment and material of
objects and entities.
Menu Item

Description
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Link

Linking is used to create hierarchies between objects. If you have one
object (child)
linked to another and then move the parent object, the child object will
move the
same way. To link one object to another you have to select one entity,
then use the
link feature and then clicking on another entity to link them together.

Unlink

This function will break the link between the objects currently selected.

Align/Snap

Align an object to the grid or to another object will move the pivot point
and
rotation parameters of the object currently selected to the one that you
click on
after you press the align to button.

Fast Rotate

Quickly rotates the current selected object on the selected axis with the
degree
value specified in the Rotate Angles Window.

Convert

Converts the selected object to a Brush, Geom Entity or Designer Object.
This can be a great option if you find you have existing assets which
need more
or less functionality.

Set Object(s) Height

Moves the object to a certain level (in meters) above the terrain.

Rename Object(s)

Renames the currently selected object.

Goto Selection

Moves the camera to the selected object (Z).

Align Object to
Surface

Moves the selected object to the surface that you next click on.

Material
Assign Current assigns the selected material to the current
selected object.
Reset To Default resets the material on the object to the default
one assigned
on object creation.
Get From Selected gets the material from the selected object to the
material editor.
Pick Material lets you pick any surfaces and then display the
surface material
in the editor.
Physics

This feature is mainly used to make a physical simulation.
For example, you could simulate wooden planks or dead bodies falling
down,
and then to cache the position of the moved objects as they would do in
real life.
Get Physics State gets the current physics state.
Reset Physics State resets the physical state (to the position
where it has
been placed originally).
Simulate Objects simulate Objects makes them behave like real
gravity
is on.

AIPoint Pick Link

Used to combine AI navigation modifier points.

AIPoint Pick Impass
Link

Used to restrict AI navigation modifier points (so AI can not walk on these
lines).

Save Objects

Save an object(s) to the game folder (Ctrl+Shift+S) as a .grp (group) file.

Load Objects

Load an object(s) from the game folder (Ctrl+Shift+L).

The Display Menu
The Display menu enables the user to toggle display features which will aid in level design, entity placement and object manipulation.
Other commands such as Remember/Goto Location and viewport navigation speed, can also be accessed from the Display menu.
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Menu Item

Description

Wireframe

Enables the Wireframe rendering mode (F3).

Point Mode

This option turns on the point mode rendering. It turns off almost
all
rendering features so editing particles can be done quicker, for
example.

Snap to Grid (value)

This locks an objects movement or rotation to a predefined grid (G
).
The current set value is displayed also.

Snap Angle

Restricts the rotation of an object to predefined angle steps,
i.e. 15, 30, 45, 60... degrees.

Ruler

Activates the Ruler tool which can be used to measure
distances.

Grid Settings...

See below for more information.

Configure Layout...

Select one of the pre-configured layout settings to help keep
arrange the
Sandbox Editor. For more information, please see the
information
on Docking Windows and Tools.

Cycle 2D Viewport

This function will change the current view port to the next type
(from perspective to top, to front) (Ctrl+Tab).

Goto Position

In this window you can specify a camera position in XYZ
coordinates, and
then hit "Go to" button to move the current camera to this
position.

Remember Location

Using this function allows you to save 10 locations that you later
recall
using the Goto Location Feature. This is useful to quickly jump
to
different predefined places in Sandbox and in Game (Ctrl+F1,
2,3,4 etc).

Goto Location

With this function you can quickly jump to the predefined
camera
positions (Shift+F1,2,3,4 etc).

Change Move Speed

Increasing the speed will make the navigation in the editor
faster.
Decreasing the speed will make the navigation in the editor
slower.
Step Size changes the Step Size to higher values to quickly
change
between fast and slow movement.

Switch Camera
Default Camera is the default camera.
Sequence Camera is used when you want to see through
the
Camera used in a Track View sequence.
Selected Camera Object is the camera entity that you
have
currently selected.
Show/Hide Helpers

Allows you to hide all helper objects or turn them back on (Shift+
Space).

Toggle Fullscreen
MainWindow

From here you can toggle the perspective viewport to & from
full screen mode. This only works when the perspective
viewport is not
docked in the main editor window.

Grid Settings
Use the Grid/Snap settings dialog box to define Grid settings, Angle Snapping values, the sizes of the construction plane and snap markers.
Grid

Confidential. © 2009-2015 Crytek GmbH. All Rights Reserved.

Page 4 of 9

Snap to Grid

Snap the selected object to the grid.

Grid Lines Every x units

The placement of grid lines measured by units.

Units Per Meter

Defines the size of a unit.

Get Angles & Translation from Selected

Rotates the grid lines & translation at angles equal to the selected object.

Rotation & Translation by X/Y/Z

Rotate the required grid line axis by the specified number of degrees.

Angle Snapping
Angle Snap

Activates/deactivates Angle Snap.

Angle Snap degrees

Sets the angle snapping steps in degrees.

Construction Plane

The Construction Plane is useful when editing Solids, or moving objects around.

Display

Switches Construction Plane on/off.

Size

Defines the size in meters in all directions from the pivot.

Snap Marker

The Snap Marker is used for modeling Solids.

Display

Turns Snap Marker on and off.

Size

Changes the size of the Snap Marker.

The Config Spec Menu
This menu allows to quickly switch between predefined quality settings, to check memory footprints, visual quality differences and features available in the
different modes.
Menu Item

Description

Very High

Turns on the Very High display settings.

High

Turns on the High display settings.

Medium

Turns on the Medium display settings.

Low

Turns on the Low display settings.

XBoxOne

Emulates Xbox One display settings.

PS4

Emulates Playstation 4 display settings.

The Group Menu
The Group menu contains commands that are concerned with the grouping of individual objects.
Menu
Item

Description

Group

When having multiple objects selected the grouping function will group them together and draw a green box
around them.

Ungroup

Having a group selected this function will ungroup all group object.

Open

This function will open the group so individual objects within the group can be modified.

Close

This function will close the group so individual object modification is no longer possible until the group is
opened again.

Attach

Having a group selected and choosing this function and then clicking on a object that is not already within the
group will add this new object to the group.

Detach

When the group is open and one of the group objects is selected this detach function will removed the specific
objects from the group.
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The Prefabs Menu
The Prefab menu contains commands to make prefabs from selection, reload prefabs and add selected objects to the prefab library.
Menu Item

Description

Create Prefab from Selected
Object(s)

Makes a new prefab from the selected objects.

Add Selected Object(s) to Prefab

Adds currently selected objects to the prefab.

Clone Selected Object(s)

Clones the selected object outside of its prefab.
Unlike "Extract", keeps original inside prefab.

Extract Selected Object(s)

Extracts the selected object from its prefab.
Unlike "Clone", removes original inside prefab.

Open All

Opens all prefabs inside the level.

Close All

Closes all prefabs inside the level.

Reload All

Reload all prefabs inside the level with the "on-disk"
version.
Only useful if prefabs are set to not automatically
update.

The Terrain Menu
The Terrain menu serves as a hub to access many view panes and tools that affect the game world and terrain appearance in particular ways.
Menu Item

Description

Edit Terrain

Opens the Terrain Editor window.

Terrain Texture Layers

Opens the Terrain Texture Layers window.

Export/Import Terrain
Texture

Used to Import and Export terrain texture tiles. Terrain tile texture
resolution can also be set here. See this article for example
usage.

Lighting

Opens the Terrain Lighting window.

Time Of Day

Opens the Time Of Day window.

Reload Terrain

Reloads the terrain.

Export Terrain Block

Exports a section of the terrain as a terrain block (.trb) file.

Import Terrain Block

Imports terrain from a previously saved terrain block file.

Resize Terrain

Opens a dialog which can set the Heightmap Resolution setting
and Meters Per Unit setting.

Terrain Modify

Opens the Modify Terrain panel with the specified tool selected.

Edit Vegetation

Opens the Vegetation Creation.

Paint Layers

Opens the Layer Painter Tool.

Refine Terrain Texture Tiles

Divides the terrain tiles into more smaller sections.

The Audio Menu
The Audio menu contains functions to stop and refresh the audio middleware system.
Menu Item

Description

Stop All Sounds

Sends a signal to the audio middleware to stop all playing sounds.

Refresh Audio

Reloads all of the audio data and sends a signal to the audio middleware that the entire
audio
system is refreshing.
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The Game Menu
The Game menu provides commands to enable the game mode and test newly created features.
Menu Item

Description

Switch to Game

Switches to game mode so you can play the level within
the editor (Ctrl+G). To exit game mode press Esc.

Enable Physics/AI

Enables the physics and AI within the editor (Ctrl+P).

Terrain Collision

Makes the editing camera collide with the terrain so you can't
fly
under the terrain surface (Q).

Synchronize Player with
Camera

Sets the player to the position where the current editing
camera is.
This can be used to prevent the camera triggering logic such
as AreaTriggers while in Editing mode.

Edit Equipment-Packs

Opens the Equipment-Packs window.
See the Setting Up Equipment Packs tutorial for more
information.

Toggle SP/MP GameRules

Switches between "SinglePlayer" and "TeamInstantAction"
game rules.

The AI Menu
The AI Triangulation menu contains commands used to generate AI navigation and update the AI system within a level.
Menu Item
Navigation
Update Mode

Description

Continues: Regenerates NavMesh while dragging geometry
on the according part of the NavMesh.
After Change: Regenerates NavMesh after finished
dragging geometry on the according part of the NavMesh.
Disabled: Does not regenerate the NavMesh that would be
affected by geometrical changes in the world.

Regenerate
Navigation

Performs a full rebuild of the NavMesh. Either all or specific
layers of the NavMesh can be selected for the rebuild.

Debug Navigation
Agent Type

Selects which NavMesh layers should be displayed, based on
their agent type.

Visualize
Navigation
Accessibility

Displays inaccessible areas as Red and accessible areas as
Blue.

Show Navigation
Areas

Displays NavMesh shapes.

Generate Cover
Surfaces

Requests generation of Cover Surfaces data.

The Tools Menu
The Tools menu is where you reload scripts, textures, geometry and terrain. Other commands include user command configuration and check level for
errors.
Menu Item

Description

Reload Scripts

Provides functions to reload specific (or all)
game scripts.

Reload Textures/Shaders

Reloads all textures and shaders used in the
level.

Reload Geometry

Reloads geometries used in the level.
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Reload Terrain

Initiates the Terrain (can be used instead of
reloading the editor).

Resolve Missing Objects/Materials

This will run a check through the level and try to
resolve all
objects / materials that have problems.

Enable file change monitoring
Clear Registry Data

Resets the Sandbox data stored in the Windows
Registry.

Check Level for Errors

Checks the level for errors (duplicate objects,
missing assets) and displays a list in the
console.

Check Object Positions
Saves level statistics to the
"YOURLEVELNAME.xml" file
in the folder:
<root>\TestResults folder.

Save Level Statistics

(Advanced) Compile Script

Compiles an entity script.

(Advanced) Reduce Working Set

Reduces Memory consumption.

(Advanced) Update Procedural
Vegetation

Updates the Procedural Vegetation.

Customize Keyboard...

The Customize Keyboard window enables you
configure
toolbars, menus and shortcuts.

Export Keyboard Settings...
Import Keyboard Settings...
Preferences...

Editor Preferences can be set here. See Editor
Preferences.

Configure Toolbox Macros...

Function to create shortcuts to console
commands.
So common commands like display AI
parameters can be
accessed with just one mouse-click, for example.

Toolbox Macros

Displays the shortcuts to console and editor
commands as
specified in the Configure User Commands
window.

Script Help

The View Menu
The View Menu helps users to be able to customize the Sandbox Editor, and provides access to the various Sandbox Editors, user layouts, and skins.
Menu Item

Description

Open View Pane

Here you can open the various Sandbox Editor windows
(i.e Flowgraph, Trackview), as well as different view functions
that aid
in object setup.

Show Rollup Bar

Shows and hides the Rollup Bar.

Show Console

Shows and hides the Console.

Show Quick Access
Bar
Layouts
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Save Layout...

Save the current layout. If a layout has been previously
saved,
a list will appear above this menu option. This will allow you
to load,
re-save, rename or delete the user layout.

Restore Default
Layout...

Restores the default layout.

Skinning
No Skinning

Set to standard Windows-style theme.

Dark Skin

Apply the "Dark Skin" theme. This is used by default.

Light Skin

Apply the "Light Skin" theme.

The Help Menu
The Help Menu contains version information as well as access to the Tip of the Day dialog box.
Menu Item

Description

Tip of the Day

Opens the Tip of the Day dialog box, and allows users to turn
"Show tips on startup" on and off.

About Editor

Displays CryENGINE Sandbox Editor version information.

Online Documentation

Opens the http://docs.cryengine.com website in your default browser.
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