Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

How to create minimaps

Table of Contents

Overview

The following walkthrough gives you an overview on how to create minimaps using the Cryengine editor and Photoshop.

Creating a minimap

Getting started

To start off doing minimaps you will have to edit the

HTML
<strong><STRONG></STRONG>

MapScreenshotSettings.xml* with Notepad , the xml file is located in the *\Editor

HTML
</strong>

folder.

A lot of these settings can be tweaked to create the most desirable result, also make sure to create a backup copy of the original

HTML
<strong><STRONG></STRONG>

MapscreenshotSettings.xml

</strong>
HTML

.

HTML
<strong><STRONG></STRONG>
HTML
<**settings>
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_fog value="1" />
HTML
</strong>
  • HTML
    <<u><<U></U>
    HTML
    </u>
    e_shadows value="0" />*
HTML
<strong><STRONG></STRONG>
HTML
<**r_PostProcessEffects value="0" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**r_HDRRendering value="0" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_detail_materials value="1" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_gsm_range_step value="20" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_gsm_lod_num value="3" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_gsm_range value="20" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_gsm_cache value="0" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_detail_materials_view_dist_z value="256" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_vegetation_sprites_distance_ratio value="4" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_shadows_cast_view_dist_ratio value="1" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**r_EyeAdaptationFactor value="0" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**r_EyeAdaptationBase value="1" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**r_HDRRendering value="1" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_lod_ratio value="4" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_clouds value="0" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_water_ocean value="1" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_particles value="0" />
</strong>
HTML
HTML
<strong><STRONG></STRONG>
HTML
<**e_view_dist_ratio value="800" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**e_hw_occlusion_culling_water value="0" />
HTML
</strong>
HTML
<strong><STRONG></STRONG>
HTML
<**/settings>
</strong>
HTML

HTML

...

<STRONG></STRONG>
Step.1
HTML

...

First open up the desired level in the Editor that you want create a minimap for.

HTML

...

<STRONG></STRONG>
Step.2
HTML

...

</strong>

Next we’ll Next we'll open up the minimap function; this is located in the

HTML
<strong><STRONG></STRONG>

RollupBar* , in the *Terrain

HTML
</strong>

pane.

Now when pressing the minimap button, a green bounding box, and a smaller blue “selection” "selection" box will appear on the terrain, this is sometimes at the 0,0,0 map coordinates.

...

To move the minimap bounding box, click and hold the right mouse button and move the blue “selection” "selection" box to the spot where you want to create your minimap.

HTML

...

<STRONG></STRONG>
Step.3
HTML

...

</strong>

After you have moved the box, press the "

HTML
<strong><STRONG></STRONG>

Use New Mini Map Area

HTML
</strong>

”button "button to update the minimap bounding box to its new location.

The green bounding box shows the area that will be made into a minimap image, adjusting the camera height will therefore change the size of it.

To change the

HTML
<strong><STRONG></STRONG>

Camera Height* , put the preferred height into the input box and press " *Use New Mini Map Area

HTML
</strong>

".

Adjusting the

HTML
<strong><STRONG></STRONG>

Resolution

</strong>
HTML

in the minimap properties will increase the size of the minimap image that the Editor generates, for example choosing a resolution of 2048 will give you a minimap image of 2048x2048 pixels.

HTML

...

<STRONG></STRONG>
Step.4
HTML

...

Before going to

HTML
<strong><STRONG></STRONG>

step.5

HTML
</strong>

, make sure that the minimap bounding box is actually bigger than the actual play area of your map, so that when a player stands on the border of your map he doesn’t doesn't get cut off on the HUD radar.

This is an important step and rule to keep in mind when creating minimaps, to prevent having to redo your minimap.

HTML

...

<STRONG></STRONG>
Step.5
HTML

...

</strong>

Now, when you’re you're all set and have selected your

HTML
<strong><STRONG></STRONG>

Camera Height* , Resolution and area, be sure to select hexadecimal or even numbers for the *Camera Height

</strong>
HTML

, if you know that you will add more detail to the minimap later on, i.e 256, 512, 1024, 2048 etc.

You can now go ahead and press the

HTML
<strong><STRONG></STRONG>

Generate !MiniMap

HTML
</strong>

button.

A quick succession of images will flash in the upper left corner, showing that the editor is creating your minimap; this can take a few minutes depending on the

HTML
<strong><STRONG></STRONG>

Camera Height* , Resolution and *MapScreenshotSettings.xml

</strong>
HTML

.

(Note though that you should only choose to use very large resolutions i.e. 8192 or 16384, if you are running the editor on a very high spec system with a minimum of 8 GB of ram)

After the editor has finished, your minimap should be placed in

HTML
<strong><STRONG></STRONG>

\Game\ScreenShots\Map

HTML
</strong>

along with the .XML file

The xml provides the engine with the map coordinates so that the player position is correctly displayed on the minimap.

Preparing your minimap

HTML

...

<STRONG></STRONG>
Step.1
HTML

...

</strong>

In Photoshop open up the minimap image file that was just created.

To make sure that your minimap will display correctly in the game you will need to desaturate your image and tweak its “levels”"levels".

HTML

...

<STRONG></STRONG>
Step.2
HTML

...

To desaturate your minimap image go to Image>Adjustments>Desaturate, this will essentially make your minimap black & white.

HTML

...

<STRONG></STRONG>
Step.3
HTML

...

</strong>

Now we’ll Now we'll need to adjust the levels, as a color overlay will be applied on top of the final image, you will need to have some outstanding black and white’s white's and clear grey tones, the better the levels are adjusted the more details players will be able to recognize.

...

To start off, go to Image>Adjustments>Levels, this will open up the “levels” "levels" output box.

By adjusting the input levels you can create a well contrasted image.

HTML

...

<STRONG></STRONG>
Step.4
HTML

...

</strong>

Now Go to File>Save As, this will open up the save as window, under formats choose the crytifplugin

Go ahead and press

HTML
<strong><STRONG></STRONG>

save* now as this will start the *crytifplugin

</strong>
HTML

, which has a wide range of settings and options – but we only need to use a few.

HTML

...

<STRONG></STRONG>
Step.5
HTML

...

First, change the Preset option from its default (diffuse_highQ) to

HTML
<strong><STRONG></STRONG>

Minimap

HTML
</strong>

.

HTML

...

<STRONG></STRONG>
Step.6
HTML

...

</strong>

Next go to the

HTML
<strong><STRONG></STRONG>

Advanced

HTML
</strong>

pane and check to make sure that “Auto "Auto Optimize file” file" is unchecked.

You can now go ahead and press

HTML
<strong><STRONG></STRONG>

OK* , *crytifplugin

HTML
</strong>

will now go ahead and create a .TIF file – don’t don't worry about the end file size.
The Resource Compiler will automatically create a .dds file for the target platform, specified in its settings.

HTML
<strong><STRONG></STRONG>

IMPORTANT

HTML


</strong>
HTML

...

<STRONG></STRONG>

you do not need the Cry Tif plugin for Photoshop to create a minimap.

</strong>
HTML


HTML

...

<STRONG></STRONG>

Just use the .dds plugin from Nvidia to export the minimaps as DXT1 from Photoshop.

</strong>
HTML

HTML

...

<STRONG></STRONG>
Step.7
HTML

...

</strong>

The minimap is now ready to be used, select the .TIF file and the xml file that was created when you made your minimap and copy both files to your map folder.

If you already have an xml file located in your map folder, you can merely open it with

HTML
<strong><STRONG></STRONG>

notepad

HTML
</strong>

.

Inside the xml file you will need to edit the numbers in the first line that shows the

HTML
<strong><STRONG></STRONG>

startX* , startY , endX and *endY

</strong>
HTML

, exchange the numbers here with the numbers located in your minimap xml file.

Make sure that the

HTML
<strong><STRONG></STRONG>

MiniMap Filename

HTML
</strong>

points to the filename of your new minimap .dds image file.

...

The minimap is now visible in your map.

Adding detail to your minimap

This process will require you to create several smaller pieces of your minimap and then later putting them together using Photoshop.

...

Before starting, make sure that you’ve you've got the

HTML
<strong><STRONG></STRONG>

NVIDIA Texture Tools

HTML
</strong>

installed in Photoshop.
(http://developer.nvidia.com/object/dds_utilities_legacy.html)

HTML

...

<STRONG></STRONG>
Step.1
HTML

...

</strong>

Now using Photoshop, open up your minimap .DDS file, the NVIDIA tools will recognize it and open up this property window, here you can just press OK .

...

With the minimap opened you can see here on this example below that the quality at 100% is not the best. We’ll We'll change that.

HTML

...

<STRONG></STRONG>
Step.2
HTML

...

Go back to the Editor, and select the minimap function.

For higher quality it’s it's enough to change

HTML
<strong><STRONG></STRONG>

Camera Height

</strong>
HTML

and keep the resolution to the original minimap, this is important otherwise you will run into issues with image sizes not matching.

You will also need to change the lines listed here below, in the

HTML
<strong><STRONG></STRONG>

MapScreenshotSettings.xml

</strong>
HTML

, these settings will raise the quality and amount of objects visible.

HTML
<e<E_detailDETAIL_materialsMATERIALS value="100000" />></E_DETAIL_MATERIALS>
HTML
<e<E_detailDETAIL_materialsMATERIALS_viewVIEW_distDIST_zZ value="1000000" />></E_DETAIL_MATERIALS_VIEW_DIST_Z>
HTML
<e<E_lodLOD_ratioRATIO value="0" />></E_LOD_RATIO>
HTML
<e<E_viewVIEW_distDIST_ratioRATIO value="100000" />

...

></E_VIEW_DIST_RATIO>

After you've edited the

HTML
<strong><STRONG></STRONG>

MapScreenshotSettings.xml* you can go ahead and press *Generate !MiniMap

HTML
</strong>

, this will again create a minimap image file and an xml file, the xml file you can safely delete as there’s there's no need for it.

HTML

...

<STRONG></STRONG>
Step.3
HTML

...

</strong>

Now go back to Photoshop and open up the minimap file the editor just created.

...

Go to your minimap that you want to add detail to, under Edit>Paste and place in the copied image.

HTML

...

<STRONG></STRONG>
Step.4
HTML

...

</strong>

After you’ve After you've done all that its time to resize the image you just pasted onto the minimap.

This is where the calculator will come in handy for you, i.e. if your minimap was created with a

HTML
<strong><STRONG></STRONG>

Camera Height

HTML
</strong>

of 512 for example; you preferably generate the smaller minimaps in increments such as 256 or 128 etc.

If you for example generate smaller minimaps with 128, that’ll that'll need to be divided by 512 to calculate the scaling percentage (128/512 = 0.25, which equals to 25% scaling.)

HTML

...

<STRONG></STRONG>
Step.5
HTML

...

</strong>

When you’ve When you've successfully scaled your minimap piece to its correct size, you’ll you'll need to move it to its correct position on the original minimap, remember to double check if it really fits correctly.

Repeat steps 2 to 5 as many times as you want to ensure that your minimap has a high level of quality.

And that’s that's it; with a little bit of extra work you will have a very high quality minimap.