Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

English

Overview

The Sandbox Editor has a built in tool for creating minimaps. Note that Scaleform needs to be installed in order to use minimaps.

Table of Contents
minlevel2

Preparing to Create a Minimap

When creating a minimap, there are certain console variables that are better left turned off. Specific adjustment of

...

CVars for minimaps are controlled in the MapScreenshotSettings.xml file.

You can edit this file, located in the <root>\Editor\ folder, with a text editor. There is also a shortcut to the file built into the

...

MiniMap Tool

...

in the RollupBar.

A lot of the settings contained in the MapScreenShotSettings can be tweaked to create the most desirable results, but make sure to create a backup copy of the original MapscreenshotSettings.xml.

The standing settings are shown here:

Code Block
languagehtml/xml
<settings>
<settings>
  <r_HDRRendering value="
0
1"/>
  <r_PostProcessEffects value="1"/>
  <r_MotionBlur value="0"/>
  <e_ScreenShotQuality value="0"/>
  <e_ViewDistRatio value="100000000"/>
  <r_DisplayInfo value="
10000">
0"/>
  <e_StreamCgfPoolSize value="128" />
  <e_VegetationSpritesDistanceRatio value="20"/>
  <e_ViewDistRatioVegetation value="100"/>
  <e_Lods value="0"/>
  <e_Vegetation value="0"/>
  <e_
TerrainLodRatio
TerrainOcclusionCulling value="0"/>
  <e_
Vegetation
OcclusionVolumes value="0"/>
</settings>

For higher quality, you can adjust the Camera Height and Resolution settings from the Mini Map tool itself. In addition, you can also change some of the lines in the .xml file, or add new

...

CVar commands.

These settings will raise the quality and the amount of objects visible.

Here is an example of some higher quality settings:

Code Block
languagehtml/xml
<e_TerrainDetailMaterials value="100000">
<e_TerrainDetailMaterialsViewDistZ value="1000000">
<e_LodRatio value="0">
<e_ViewDistRatio value="100000">

Creating a Minimap

First, open the desired level in the Sandbox Editor.

Next, open the

...

MiniMap function located

...

in the RollupBar, on the Terrain

...

panel.

Image Modified

After pressing the

...

MiniMap button, a green bounding box, and a smaller blue "selection" box will appear on the terrain. It is helpful to zoom far away from the terrain in order to see the entire area.

If you cannot see the terrain after zooming out, try increasing the ViewDistance setting under the Environment tab.

Image Modified

To move the minimap bounding box, click on a different section of the terrain where you want to create your minimap.

The green bounding box shows the area that will be made into a minimap image, adjusting the camera height will therefore change the size of it. To change the Camera Height, put the preferred height into the input box.

Make sure that the minimap bounding box is actually bigger than the actual play area of your map. Failing to do so can lead to anomalies if the player stands on the border of your map.

Adjusting the Resolution in the minimap properties will increase the size of the minimap image that the Editor generates. For example, choosing a resolution of 2048 will give you a minimap image of 2048x2048 pixels.

...

Warning

You should only choose to use very large resolutions (8192 or 16384) if you are running the editor on a very high spec system with a minimum of 8 GB of ram.

After you have moved the box and set the Resolution and Camera Height, select the Output directory and one of both of the file formats (.dds and .tif). Now press Generate MiniMap.

Image Modified

A quick succession of images will flash in the upper left corner of the Editor, showing that your minimap is being created; this can take a few minutes depending on the Camera Height, Resolution and MapScreenshotSettings.xml.

Image Modified

After the editor has finished, your minimap will be placed in

...

the same folder as the currently opened .cry file along with an .xml file.

All the associated files (*.tif, *.dds & *.xml) will adopt the level file name.

The .xml file provides the CryENGINE with the map coordinates so that the player position is correctly displayed on the minimap.

...

Internal
h2. Preparing the Minimap h3. Step 1 In Photoshop, open up the minimap image file that was just created. To make sure that your minimap will display correctly in the game, you will need to desaturate the image and tweak its levels. h3. Step 2 To desaturate your minimap image, go to Image>Adjustments>Desaturate, this will essentially make your minimap black & white. h3. Step 3 Now, adjust the levels as a color overlay will be applied on top of the final image, you will need to have some outstanding black and white and clear grey tones, the better the levels are adjusted the more details players will be able to recognize. Try to avoid creating completely black areas. To start off, go to Image>Adjustments>Levels, this will open up the "levels" output box. !image005.jpg! By adjusting the input levels you can create a well contrasted image. h3. Step 4 Now Go to File>Save As, this will open up the save as window, under formats choose the crytifplugin. !image006.jpg! Go press *save now* as this will start the *crytifplugin*, which has a wide range of settings and options. For creating MiniMaps you will only need to use a few. h3. Step 5 First, change the Preset option from its default (diffuse_highQ) to *Minimap*. !image007.jpg! h3. Step 6 Next go to the *Advanced* pane and check to make sure that "Auto Optimize file" is deselected. !image008.jpg! You can now press *OK*, and *crytifplugin* will now create a .TIF file -- don't worry about the end file size. The Resource Compiler will automatically create a .dds file for the target platform, specified in its settings. *IMPORTANT:* You do not need the CryTifPugin for Photoshop to create a minimap. You can also use the .dds plugin from Nvidia to export the minimaps as DXT1. h3. Step 7 The minimap is now ready to be used, select the .TIF file and the .xml file that was created when you made your minimap and copy both files to your map folder. If you already have an .xml file located in your map folder, you can merely open it with a text editor. Inside the .xml file you will need to edit the numbers in the first line that shows the *startX*, *startY*, *endX*, and *endY*. Exchange the numbers here with the numbers located in your minimap .xml file. !image009.jpg! Make sure that the *MiniMap Filename* points to the filename of your new minimap .dds image file. !image010.jpg! Instead of putting in .TIF as the file definition you will need to put in .dds instead (the one the Resource Compiler will create from the .TIF, or you manually created via the NVIDIA plugin). *Note:* If there are no numbers located in the .xml file, just copy the whole line from your minimap .xml file. The minimap is now visible in the map. h2. Adding Detail to the Minimap This process will require you to create several smaller pieces of your minimap and then later put them together using Photoshop. This is generally only a process you will have to do if your PC is not able to handle the creation of high resolution minimaps. Before starting, make sure that you have the *NVIDIA Texture Tools* installed in Photoshop. ([http://developer.nvidia.com/object/dds_utilities_legacy.html|http://developer.nvidia.com/object/dds_utilities_legacy.html]) h3. Step 1 Now, using Photoshop open your minimap .DDS file. The NVIDIA tools will recognize it and open up this property window, here you can just press *OK* . !image011.jpg! With the minimap opened you can see here on this example below that the quality at 100% is not the best. !image012.jpg! h3. Step 2 Go back to the Editor, and select the minimap function. For higher quality it's enough to change *Camera Height* and keep the resolution to the original minimap, this is important otherwise you will run into issues with image sizes not matching. You will also need to change the lines listed below, in the *MapScreenshotSettings.xml*. These settings will raise the quality and the amount of objects visible. {code}<E_DETAIL_MATERIALS value="100000"></E_DETAIL_MATERIALS> <E_DETAIL_MATERIALS_VIEW_DIST_Z value="1000000"></E_DETAIL_MATERIALS_VIEW_DIST_Z> <E_LOD_RATIO value="0"></E_LOD_RATIO> <E_VIEW_DIST_RATIO value="100000"></E_VIEW_DIST_RATIO>{code} After you've edited the *MapScreenshotSettings.xml*, you can press *Generate MiniMap*. This will again create a minimap image file and an .xml file, the .xml file you can safely delete as there's no need for it. h3. Step 3 Now go back to Photoshop and open up the minimap file the editor just created. Select the whole image by going to Select>All and select copy under Edit>Copy. Go to your minimap that you want to add detail to under Edit>Paste, and place in the copied image. h3. Step 4 After you've done all that, it's time to resize the image you just pasted onto the minimap. This is where the calculator will come in handy for you. If your minimap was created with a *Camera Height* of 512 for example, you should preferably generate the smaller minimaps in increments such as 256 or 128 etc. If, for example, you generated smaller minimaps with 128, that will need to be divided by 512 to calculate the scaling percentage (128/512 = 0.25, which equals to 25% scaling.) !image013.jpg! h3. Step 5 When you've successfully scaled your minimap piece to its correct size, you'll need to move it to its correct position on the original minimap. emember to double check if it really fits correctly. Repeat steps 2 to 5 as many times as you want to ensure that your minimap has a high level of quality. With a little bit of extra work you will have a very high quality minimap.

Example from Woodland level:

Code Block
languagehtml/xml
<MetaData>
 <MiniMap Filename="woodland.dds" startX="1122.5697" startY="327.42395" endX="1922.5697" endY="1127.424" width="2048" height="2048"/>
</MetaData>
Note

The generated levelname.tif will require rotating 90 Clock-Wise in an image editing program, to match the the terrain texture orientation.

Save & reload the editor to see the minimap active in the HUD.

 

 

Excerpt
hiddentrue
Use Sandbox and an image editor to create high resolution mini maps for in game use.
Chinese

创建“迷你地图”

Sandbox 编辑器有一个内置工具用以创建“迷你地图”。注意使用“迷你地图”需要安装 Scaleform。

准备创建“迷你地图”

当创建“迷你地图”时,最好让某些控制台变量处于关闭状态。在 "MapScreenshotSettings.xml" 文件中控制“迷你地图”的 Cvars 的特定调整。您可以用文本编辑器编辑此文件,它的位置在*\编辑器*文件夹。Rollup 栏上的“迷你地图工具”也内置有此文件的快捷键。

在 MapScreenShotSetting 中含有的许多设置可以进行微调以创建最佳预期的结果,但是请确保创建一个原始文件 “MapscreenshotSettings.xml”的备份副本。现有设置如下所示:

<settings>
  <r_HDRRendering value="0"/>
  <r_PostProcessEffects value="0"/>
  <e_ScreenShotQuality value="0"/>
  <e_ViewDistRatio value="100000000"/>
  <e_TerrainDetailMaterialsViewDistZ value="100000000"/>
  <r_DisplayInfo value="0"/>
  <e_StreamCgfPoolSize value="128" />
  <e_VegetationSpritesDistanceRatio value="20"/>
  <e_ViewDistRatioVegetation value="100"/>
  <e_Lods value="0"/>
  <e_TerrainLodRatio value="0"/>
  <e_Vegetation value="0"/>
  <e_TerrainOcclusionCulling value="0"/>
  <e_OcclusionVolumes value="0"/>
</settings>

为了达到更高质量,您可以调整“迷你地图”工具中的*摄像机高度*和*分辨率*设置。除此之外,您也可以改变 xml 文件中的某些行,或者添加 Cvar 新命令。这些设置将会提高可见对象的质量和数量。此处有一个高质量设置的示例:

<e_TerrainDetailMaterials value="100000">
<e_TerrainDetailMaterialsViewDistZ value="1000000">
<e_LodRatio value="0">
<e_ViewDistRatio value="100000">

创建“迷你地图”

首先,打开 Sandbox 编辑器中所需的关卡。

然后,打开*地形*窗格上* Rollup 栏*中的“迷你地图”功能。

 

按“迷你地图”按钮之后,地形上会出现一个绿色的边界框和一个小一些的蓝色选择框。它有助于从远处对地形进行缩放,以看清整个区域,如果在缩小后无法看清区域,请尝试增加“环境选项卡”下的“视图距离”设置。

 

若要移动迷你地图的边界框,请在您想创建地图的地形上单击不同区域进行选择。

绿色边界框显示的区域将生成“迷你地图”的图像,调整摄像机的高度可以改变其大小。请在输入框内填入最佳高度以改变*摄像机高度*。

请确保迷你地图的边界框比您在地图上实际游戏的区域要大。如果没有这样做,当玩家站在地图的边界上时可能会导致异常情况。

在迷你地图属性中调整分辨率将增加编辑器生成的迷你地图的图像大小。例如,选择 2048 分辨率将使您的迷你地图图像像素为 2048x2048。

*注:*如果您在最小内存为 8 GB 的高规格系统上运行编辑器,您应当只选择使用非常大的分辨率(例如:8192 或 16384)。

您移动边界框并设置分辨率及摄像机高度之后,请选择输出目录和文件格式(dds 或 tif)。现在请按*“生成迷你地图”*。

 

编辑器的左上角会出现快速连续的闪烁图像,表示您的迷你地图正在创建。创建将花费几分钟,时间长短取决于*摄像机高度*、分辨率*和 *MapScreenshotSettings.xml

 

编辑器完成工作之后,您的迷你地图将同 .xml 文件一起放在当前打开的.cry 文件的文件夹中。

.xml 文件为 CryENGINE 提供地图坐标,以使玩家在迷你地图上显示出正确的位置。