Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

<settings>
<e_fog value="1" />
<e_shadows value="0" />
<r_PostProcessEffects value="0" />
<r_HDRRendering value="0" />
<e_detail_materials value="1" />
<e_gsm_range_step value="20" />
<e_gsm_lod_num value="3" />
<e_gsm_range value="20" />
<e_gsm_cache value="0" />
<e_detail_materials_view_dist_z value="256" />
<e_vegetation_sprites_distance_ratio value="4" />
<e_shadows_cast_view_dist_ratio value="1" />
<r_EyeAdaptationFactor value="0" />
<r_EyeAdaptationBase value="1" />
<r_HDRRendering value="1" />
<e_lod_ratio value="4" />
<e_clouds value="0" />
<e_water_ocean value="1" />
<e_particles value="0" />
<e_view_dist_ratio value="800" />
<e_hw_occlusion_culling_water value="0" />
</settings>

Step

...

1
HTML

First open up the desired level in the Editor that you want create a minimap for.

HTML
<B></B>
Step

...

2
HTML

Next we'll open up the minimap function; this is located in the RollupBar, in the Terrain pane.

...

To move the minimap bounding box, click and hold the right mouse button and move the blue "selection" box to the spot where you want to create your minimap.

HTML
<B></B>
Step

...

3
HTML

After you have moved the box, press the Use New Mini Map Area button to update the minimap bounding box to its new location.

...

Adjusting the Resolution in the minimap properties will increase the size of the minimap image that the Editor generates, for example choosing a resolution of 2048 will give you a minimap image of 2048x2048 pixels.

HTML
<B></B>
Step

...

4
HTML

Before going to step.5, make sure that the minimap bounding box is actually bigger than the actual play area of your map, so that when a player stands on the border of your map he doesn't get cut off on the HUD radar.

This is an important step and rule to keep in mind when creating minimaps, to prevent having to redo your minimap.

HTML
<B></B>
Step

...

5
HTML

Now, when you're all set and have selected your Camera Height, Resolution and area, be sure to select hexadecimal or even numbers for the Camera Height, if you know that you will add more detail to the minimap later on, i.e 256, 512, 1024, 2048 etc.

...

The xml provides the engine with the map coordinates so that the player position is correctly displayed on the minimap.

Preparing Your Minimap

HTML
<B></B>
Step

...

1
HTML

In Photoshop open up the minimap image file that was just created.

To make sure that your minimap will display correctly in the game you will need to desaturate your image and tweak its "levels".

HTML
<B></B>
Step

...

2
HTML

To desaturate your minimap image go to Image>Adjustments>Desaturate, this will essentially make your minimap black & white.

HTML
<B></B>
Step

...

3
HTML

Now we'll need to adjust the levels, as a color overlay will be applied on top of the final image, you will need to have some outstanding black and white's and clear grey tones, the better the levels are adjusted the more details players will be able to recognize.

...

By adjusting the input levels you can create a well contrasted image.

HTML
<B></B>
Step

...

4

HTML

Now Go to File>Save As, this will open up the save as window, under formats choose the crytifplugin

...

Go press save now as this will start the crytifplugin, which has a wide range of settings and options – but we only need to use a few.

HTML
<B></B>
Step

...

5
HTML

First, change the Preset option from its default (diffuse_highQ) to Minimap.

HTML
<B></B>
Step

...

6
HTML

Next go to the Advanced pane and check to make sure that "Auto Optimize file" is unchecked.

...

Just use the .dds plugin from Nvidia to export the minimaps as DXT1 from Photoshop.

HTML

HTML
<B></B>
Step

...

7
HTML

The minimap is now ready to be used, select the .TIF file and the xml file that was created when you made your minimap and copy both files to your map folder.

...

Before starting, make sure that you have the NVIDIA Texture Tools installed in Photoshop. (http://developer.nvidia.com/object/dds_utilities_legacy.html)

HTML
<B></B>
Step

...

1
HTML

Now using Photoshop, open up your minimap .DDS file, the NVIDIA tools will recognize it and open up this property window, here you can just press OK .

...

With the minimap opened you can see here on this example below that the quality at 100% is not the best. We'll change that.

HTML
<B></B>
Step

...

2
HTML

Go back to the Editor, and select the minimap function.

...

After you've edited the MapScreenshotSettings.xml you can go ahead and press Generate !MiniMap, this will again create a minimap image file and an xml file, the xml file you can safely delete as there's no need for it.

HTML
<B></B>
Step

...

3
HTML

Now go back to Photoshop and open up the minimap file the editor just created.

...

Go to your minimap that you want to add detail to, under Edit>Paste and place in the copied image.

HTML
<B></B>
Step

...

4
HTML

After you've done all that its time to resize the image you just pasted onto the minimap.

...

If you for example generate smaller minimaps with 128, that'll need to be divided by 512 to calculate the scaling percentage (128/512 = 0.25, which equals to 25% scaling.)

HTML
<B></B>
Step

...

5
HTML

When you've successfully scaled your minimap piece to its correct size, you'll need to move it to its correct position on the original minimap, remember to double check if it really fits correctly.

...