Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Image Removed

Image Added

 

Overview

Sections

Sandbox comes with a number of different options when it comes to terrain importing and exporting, including, but not limited to, exporting to FBX Terrain blocks.


Image Added


Table of Contents
minLevel2

Selecting Terrain

To get started, we'll select a small piece of terrain located within the Woodland sample level that ships with the CRYENGINE SDK.

To select terrain, click on the Terrain Editor on the right side of the screen. Then proceed to click Edit->Select Terrain to access the terrain tool.

Now, while avoiding selecting any entities/brushes in the level, drag your mouse across the terrain to form a shape.

Exporting To Terrain Block

As mentioned earlier, there are numerous different options available when dealing with terrain in CRYENGINE.

To get started, we're going to do the in-engine option which Exporting to a Terrain Block file (.trb). Exporting to Terrain Block will export both the terrain shape and vegetation objects within that terrain radius.

To export to Terrain Block, simply click on the "Terrain" menu and then "Export to Terrain Block". This will open up a file dialog where you can choose location and filename of your Terrain Block file.

One final step before we close Forest will be to export the terrain layers, the reason for this will be realized during the import phase. See Layer Import and Export for information on how to do this.

Importing From Terrain Block

It is important to note that when you import a terrain block that the heightmap dimensions must match from source to destination levels.

To showcase this feature, we'll import our previously exported Terrain Block from Forest, into a brand new level.

Simply click on the Terrain menu and "Import Terrain Block" then select your .trb file which was exported in the previous section.

You'll notice by default, the terrain doesn't look quite right. This is because the terrain layers have not been imported into the new level.

If you followed the instructions earlier you should now be able to import the terrain layers and after some brief re-painting, you should have something a bit more like this:

Exporting Terrain To FBX/OBJ

Following on from the Select Terrain section above, now that we have our terrain selected, lets export it so we can use it inside a DCC tool.

To do, click File -> Export Terrain Area

This will open a file dialog which allows you to save the selected terrain to either FBX or OBJ file formats.

Let's see how it looks inside 3ds Max!

Exporting Terrain and Objects to FBX/OBJ

Similar to above, have your terrain area selected and then click File -> Export Terrain Area with Objects.

The difference with this method is not only will your terrain mesh be exported, but also any objects within the boundary of the area selection.

As you can see, in addition to the terrain mesh, assets within the bounds have also been saved to the FBX file, including the hemispherical skydome asset from the Forest level.